BSOD CRITICAL_STRUCTURE_CURRUPTION (win32k.sys)

#1
Hello,
I recently bought a 120gb OCZ Agility SSD for my desktop build. I installed the SSD into the case and used my $40 promotional Windows 8 64-bit Pro copy on the new SSD. The install and initial setup went fine. Except I could not find the "memory remapping" option in my BIOS anywhere! Nor could I find "SATA mode" all I could find was "RAID mode" so I switched that to AHCI.
After install I used a couple of different guides to optimize/tweak the settings in Win8 so that it would perform as best it could with my SSD. That all went fine as well.
Once I actually started using my computer, the troubles began. Every time I start to use the computer just a little extensively it freezes for a second and then that annoying BSOD comes up with the error "CRITICAL_STRUCTURE_CURRUPTION (win32k.sys)"...I shrank my paging file so that it would stay within the size of 512mb to 2049mb. I did this after the first two times that the error occurred because I thought it might've been an issue with RAM. However, this still happens every time I begin to open more than 3 programs or start moving files and stuff "too fast". It also might be worth mentioning that I had a 2gb RAMdisk that I was using for Windows' temp files...but I stopped that and now the temp files are stored on a different internal HDD. My drivers are all good (that I know of).
The only thing I can think of is my RAM...it's a 2x4 configuration, totaling in 8gb. I've ran Memtest on each stick for 12hrs and it went without a hitch. I may have them in the case wrong...may sound dumb, but I'm not sure which numbered slots to put them in. They were in numbers 1 & 3 (had BSOD) so I changed them to slots 2 & 4.
I'm at a loss here. I hope someone can help. Thanks in advance, Preston.
 


Attachments

usasma

Fantastic Member
Microsoft Community Contributor
#2
There are no memory dumps in the uploaded reports.
Please check in C:\Windows\Minidump to see if they are there. If so, please zip them up and upload them.
If not, please follow the instructions here: Set MiniDump

Then check in C:\Windows to see if there's a MEMORY.dmp file there. If there is, please zip it up and upload it to a free file hosting service. Then post a link to it here so we can download it.

We've seen a number of BSOD issues with SSD's. Here's the information that I've compiled so far:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Update the motherboard controllers drivers to the latest available version from the controller manufacturer (NOT the mobo manufacturer unless you can't find any on the controller manufacturer's website)
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
- Update chipset and storage controller drivers to the latest available from the manufacturer of the device (not the manufacturer of the motherboard). Be sure to update ALL controllers on the motherboard!
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.
- Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
It's my opinion that SSD's aren't reliable enough (with current hardware) to be used on a system that needs to work reliably. Until I see reliability I will not recommend, nor will I use, SSD's for critical applications.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
29 May 2012 - The frequency of BSOD's with SSD's seems to have been decreasing over the last several months. It may be approaching time to re-evaluate my stand on their suitability for use in production systems.
10 Nov 2012 - I'm seeing an upswing in SSD errors - but most appear due to older storage controller drivers. I strongly suggest NOT using storage controller drivers that don't date from 2012 (if none are available, don't connect an SSD to that controller)
05 Jan 2013 - very interesting post about difficulties with the Marvell controllers even when not connected to the SSD drives: https://www.eightforums.com/bsod-cr...-pc-reboots-when-waking-sleep.html#post169956
Your BIOS dates from 2011. Please check at the manufacturer's website to see if there are any BIOS updates available for your system. Also check the readme file to see if they apply to the problems that you are having. Please be advised that flashing the BIOS is a very unforgiving process - and one mistake can physically damage your motherboard.

You have a Realtek RTL8187 Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter:
I do not recommend using wireless USB network devices. Especially in Win7/Win8 systems.
These wireless USB devices have many issues with Win7(and I suspect with Win8) - using Vista drivers with them is almost sure to cause a BSOD.
Should you want to keep using these devices, be sure to have Win7/Win8 drivers - DO NOT use Vista drivers!!!
An installable wireless PCI/PCIe card that's plugged into your motherboard is much more robust, reliable, and powerful.
You have 3 hard drives. What is the make/model/wattage and age of your Power Supply?

There are problems with this device:
USB Mass Storage Device USB\VID_14CD&PID_8123\812320080329 This device cannot start.
I can't seem to locate what this device is. I'll try again after dinner.......
 


#3
There were no files in the Minidump folder, there was also no MEMORY.dmp file. I followed the instructions from your website to set that up.

I have the newest firmware available for my Mobo :( What readme file are you referring to, exactly?

The network adapter that I have is very good, it has an external antenna and picks up my home wireless as if it were right next to my desk, I would rather not have to spend even more money than I already have to buy yet another Wi-Fi adapter (I've purchased several over the last couple of months.) The Realtek USB adapter that I'm using is an Alfa AWUS036H and the drivers that I used are the Windows 7 version. It is working flawlessly, but, if you think this is the cause than I will spend a couple bucks to buy a PCI/internal adapter.

I have a Corsair CX430 430W PSU. The device that won't start is most likely my USB SD card reader, for some reason it has to be unplugged and then plugged back in once my computer restarts. Not a big issue there. Also, I have one internal HDD, 1 internal SSD, and an external HDD.

How do I go about updating my controllers and such? I have no clue as to what brand they are...all I know is that my motherboard is an MSI H55-E33.

Thanks for the reply!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.