BSOD Might be Hardware, but I can't tell

#1
Hello all, I hate for this to be my first post, but oh well. I've seen threads similar to this one but of course not the same. I've been getting BSODs lately. First it started with a couple while I was sleeping, then they started to happen while I was using the computer, and eventually got so bad that I couldn't even boot to the BIOS with out multiple tries. I believe it is hardware related, but I don't know what hardware is causing the problem.

Things I've done:
Reinstalled the entire OS
Took out all but 2 gigs of RAM (based on some other thread's suggestions)
Reseated Video Card and Ram, as well as reset the BIOS by removing the battery.
After Reinstalling OS, removed the nVidia HD Audio Drivers, they may reinstall during reboot though...

View attachment Dumps.zip
Any help or insight is appreciated. I'm still well with-in warranty of my video card, and I want to get more RAM anyways, so I wouldn't mind finding out they are broken, I just need to know if they are.

Some System Specs:

Windows 7 Ultimate 64-bit
AMD Athlon 64 x2 6000+ (Windsor 90nm Tech...)
2.0 GB Dual-Channel DDR2 @ 334 MHz (5-5-5-15) *3 before removing some. Going to upgrade to 8)
ECS Nettle2 MOBO
nVidia GeForce GTS 450 (I think it's the audio drivers on this one that causes it)
488 gb Western Digital WDC WD50

That might be more than you need, but once again THANKS!
 


Captain Jack

Extraordinary Member
#2
Hi there,

Seems like the causes of crashes are random so more likely it could be some Hardware that's causing the system to crash. Go follow this link Hardware Diagnostic | Captain Debugger and run a complete Hardware Diagnostic

If your Overclocking please reset to default settings.

Update the following Drivers:

Code:
SoftK56 Modem Driver:
VSTCNXT6.SYS Thu Oct 16 06:22:22 2008
VSTDPV6.SYS  Thu Oct 16 06:27:45 2008
VSTBS26.SYS  Thu Oct 16 06:24:06 2008 

[B][COLOR=#ff0000]RTCore64.sys Wed May 25 12:09:12 2005[/COLOR][/B] - Afterburner  (Very important should update to remove it)

Code:
MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000000403, The subtype of the bugcheck.
Arg2: fffff68000020fd8
Arg3: feb000004c8de867
Arg4: ffffc68000020fd8

Debugging Details:
------------------


BUGCHECK_STR:  0x1a_403

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  svchost.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff80002f407d8 to fffff80002ece700

STACK_TEXT:  
fffff880`04f3b7b8 fffff800`02f407d8 : 00000000`0000001a 00000000`00000403 fffff680`00020fd8 feb00000`4c8de867 : nt!KeBugCheckEx
fffff880`04f3b7c0 fffff800`02eff401 : 00000000`00000000 fffff680`00020ff8 fffffa80`01948630 00000000`00048093 : nt! ?? ::FNODOBFM::`string'+0x31eb2
fffff880`04f3b970 fffff800`02f1016a : 00000000`00000000 00000000`04f95fff fffffa80`00000000 fffffa80`00000000 : nt!MiDeleteVirtualAddresses+0x408
fffff880`04f3bb30 fffff800`02ecd953 : ffffffff`ffffffff 00000000`0145ebf8 00000000`0145ebf0 00000000`00008000 : nt!NtFreeVirtualMemory+0x5ca
fffff880`04f3bc20 00000000`7782f89a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0145ebb8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7782f89a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt! ?? ::FNODOBFM::`string'+31eb2
fffff800`02f407d8 cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+31eb2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4d9fdd34

FAILURE_BUCKET_ID:  X64_0x1a_403_nt!_??_::FNODOBFM::_string_+31eb2

BUCKET_ID:  X64_0x1a_403_nt!_??_::FNODOBFM::_string_+31eb2

Followup: MachineOwner
---------
 


#3
Hello,

Thanks for the reply. I believe I've done everything you asked.

I ran MemTest86+ with no errors reported.
Ran chkdsk without problems.
Reset the OC to factory (btw, it's factory OC'd, here's a link to the card: Newegg.com - GIGABYTE GV-N450OC-1GI GeForce GTS 450 (Fermi) 1GB 128-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card, ) View attachment 13931 and then uninstalled Afterburner
Reinstalled all the nVidia drivers, and stress tested with furmark. Never have gotten over 80 degrees, so it's not a heat problem.
Update the drivers you asked. I updated my modem driver through the device manager, 'successfully.' They now show a 2009 date.

Also, I noticed that when it crashes when I use it the audio hangs and repeats itself (like a loop of a eighth of a second). I don't use the HDMI cable, so the audio drivers are useless to me, but disabling them didn't see to work as I have had a few more BSOD while I was away. I'll attach them, thanks!

View attachment new dumps.zip
 


Captain Jack

Extraordinary Member
#4
Hi there,

Do you use any third party Antivirus / Firewall? If so uninstall it completely and use the removal tool and cleanup the left over files. Enable Driver Verifier Using Driver Verifier to identify issues with Drivers - Windows 7 Forums for 36 hours.

Run SFC /SCANNOW SFC /SCANNOW to Repair Windows 7 Files | Captain Debugger

Report us back with results
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
I believe the RTcore64 file is associated with the EVGA Precision software. The 2005 file has been replaced recently with a 2011 version if you download the new version of that utility. So if you are using that utility, or have used it, you might want to check.

If you are no longer using it, you might want to check msconfig.exe to see if it is still listed during startup.

FYI, the 32 bit version is still dated 2005.
 


#6
Captain: Thanks for the reply, I do NOT have a 3rd party firewall installed as of now. I have yet to install ESET nod32, but will once everything is working. I will have to wait until tomorrow to enable driver verification and to run SFC because I have to finish a graduation video. (Party is tomorrow). I'll report back with results then.

Saltgrass: RTCore is not listed in my start-up nor services tab under msconfig. I do not have a EVGA card, and cannot find the EVGA Precision software anywhere on my add/remove programs. If you suggest it I will install the EVGA Percision if you think it will help.


The good news is: I haven't had any BSOD's logged in the minidump folder since my last post. I even had mIRC running all night so I know it didn't even shut down. Maybe we are getting somewhere!

Thanks again guys
 


#7
After around 20 failed attempts at booting and a rediculous about of blue screening the past day, I was going through the bios and I disabled a setting in the BIOS under the advanced tab. It was the PS/2 setting, which I disable because it said it would "Free up IRQ12". I remember on a lot of the BSODs it mentioned IRQ something something, so I disabled it and it booted fullyon the first try. Restarted, and it booted again perfectly. Third time worked as well. After browsing on firefox I got this BSOD (newest folder) which appears to be different then the other ones, any suggestions?

View attachment Moar BSOD.zip



I can do the Driver Verifier too if that will help, yes/no?

Thanks!
 


Captain Jack

Extraordinary Member
#8
Hi there,

Seems like VKbms.sys i.e. Virtual HID Minidrive could be causing it . I would recommend to remove it. Also Yes I would recommend to Enable Driver Verifier.

Code:
Unable to load image \SystemRoot\system32\DRIVERS\VKbms.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for VKbms.sys
 


#9
I enabled driver verifier and these where the Bluescreens that may or may not have resulted from it:

View attachment Post DV.zip





I also ran SFC as directed and when it was finished it said this:
Verification 100% complete.
Windows Resource Protection did not find any integrity violations.
Note: The first SFC I ran was interrupted at around 50% by a "Memory Management" bluescreen. I was on Firefox :)

If it helps, these are the files that are now in the Windows>Logs>CBS folder, exactly how I found them.

View attachment CBS.zip


Thanks again Captain!
 


#10
I got another blue screen this morning that said "DRIVER_CORRUPTED_MMPOOL" and using BlueScreenView it says it was caused by ntoskrnl.exe. Reading around I found:
In my experience if this is a hardware fault it's invariably memory ?
Time for some new RAM?

Here's the dmp file.

View attachment 060711-15178-01.zip
 


Last edited:

Captain Jack

Extraordinary Member
#11
Hello there,

Seems like the new dump file is referring to hard drive and reg booster. Do you any external HDD connected? If so remove it. If there is any then run Hard drive Diagnostic. You'll find the tool in manufacture's website.


Code:
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000006, The exception code that was not handled
Arg2: fffff80002f513ef, The address that the exception occurred at
Arg3: fffff880009a97f8, Exception Record Address
Arg4: fffff880009a9060, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at "0xlx" referenced memory at "0xlx". The required data was not placed into memory because of an I/O error status of "0xlx".

FAULTING_IP: 
nt!_report_gsfailure+5f
fffff800`02f513ef 3a0c10          cmp     cl,byte ptr [rax+rdx]

EXCEPTION_RECORD:  fffff880009a97f8 -- (.exr 0xfffff880009a97f8)
ExceptionAddress: fffff80002f513ef (nt!_report_gsfailure+0x000000000000005f)
   ExceptionCode: c0000006 (In-page I/O error)
  ExceptionFlags: 00000000
NumberParameters: 3
   Parameter[0]: 0000000000000000
   Parameter[1]: 00000000770f5855
   Parameter[2]: 00000000c0000428
Inpage operation failed at 00000000770f5855, due to I/O error 00000000c0000428

CONTEXT:  fffff880009a9060 -- (.cxr 0xfffff880009a9060)
rax=fffff80003398aa0 rbx=0000000076fe0000 rcx=0000000000000052
rdx=0000080073d5cdb5 rsi=fffff880009a9ad0 rdi=fffff80003398aa0
rip=fffff80002f513ef rsp=fffff880009a9a38 rbp=fffff80003398aa0
 r8=00000000000000f7  r9=00000000770ec3a4 r10=000000000000007b
r11=00000000770ed8f0 r12=fffff80003387838 r13=0000000000000000
r14=0000000000000007 r15=0000000000000002
iopl=0         nv up ei pl nz na pe cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010203
nt!_report_gsfailure+0x5f:
fffff800`02f513ef 3a0c10          cmp     cl,byte ptr [rax+rdx] ds:002b:00000000`770f5855=??
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VERIFIER_ENABLED_VISTA_MINIDUMP

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000006 - The instruction at "0xlx" referenced memory at "0xlx". The required data was not placed into memory because of an I/O error status of "0xlx".

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  00000000770f5855

EXCEPTION_PARAMETER3:  00000000c0000428

IO_ERROR: (NTSTATUS) 0xc0000428 - <Unable to get error code text>

BUGCHECK_STR:  0x7E

EXCEPTION_STR:  0xc0000006_c0000428

FOLLOWUP_IP: 
+1a7952f009adfdc
00000000`770f5855 ??              ???

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: hardware_disk

IMAGE_NAME:  hardware_disk

DEBUG_FLR_IMAGE_TIMESTAMP:  0

STACK_COMMAND:  kb

FAILURE_BUCKET_ID:  X64_0x7E_VRF_IMAGE_hardware_disk

BUCKET_ID:  X64_0x7E_VRF_IMAGE_hardware_disk

Followup: MachineOwner
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#12
Since I am still learning about Dump files, I wonder about things such as drivers that have been unloaded. The one below seems to show up and appears to be from Conexant:

Unloaded modules:
fffff880`03aff000 fffff880`03b6f000 CAXHWBS2.sys
Captain is right about the rdyboost indication, but that is a Microsoft system file so perhaps something else if at the root of the problem.

MODULE_NAME: rdyboost
IMAGE_NAME: rdyboost.sys
DEBUG_FLR_IMAGE_TIMESTAMP: 4a5bc48a
FAILURE_BUCKET_ID: X64_0xD0_VRF_rdyboost!SmdMdlAllocate+31
BUCKET_ID: X64_0xD0_VRF_rdyboost!SmdMdlAllocate+31
I have gotten Verifier to give me a blue screen on my 32 bit system for a Microsoft driver. SP1 seems to have fixed it since that no longer happens. But basically, Verifier might show blue screens on something that would not otherwise cause problems, even though the driver might be deficient. So you might disable the verifier, whenever you are ready, to see if the blue screens continue.
 


#13
Thanks again for the responses.

Captain: I do not have any external drives (unless you count my Archos 5, which has a 160 gb hd on it...hmmm, that's disconnected now) and I went to Western Digital's website for their Diagnostics program. I was able to use Speccy to get the model of my HD, so I got the correct version of the Diagnostics for it. Upon running the program, it was unable to tell me the hard drives serial number.

I ran a "quick test" and it came back with no errors; however, upon running what I think was called the "Full Test" it was not so error free. The test itself ran fine, and ended with this screen.

077b8dcb34f95f4d2214c3bb6fd0c2ac.png

I then clicked repair (seeing as I already have everything backed up) and got this:

7aedd7544495821cc8430055c8b42976.png


So can we now say for sure it is a hard drive error? I can admit that I may be to blame. A few months ago either the hard drive or the fan started getting loud (like a playing card in a bike wheel kind of noise) so I would give 'er a slap and it would quiet it down. This never resulted in a immediate blue screen, but I can see how that would cause problems.

Also, let me ask if "writing zeros" would help at all.


Thanks.

As for Salt Grass: I had blue screens before enabling, during, and after using Driver Verifier.


I can attach the dumps I've been getting, if more research is needed.
 


#14
Do I have the green light to buy a new Hard Drive? I was thinking about getting either a velocoraptor drive from WD or a SSD as my OS Drive, and a 2tb WD drive for data. But if the Hard Drive is not the problem, I will put the money elsewhere.
 


Captain Jack

Extraordinary Member
#15
Run the drive test again and see if giving errors about bad sectors.
 


#16
Run the drive test again and see if giving errors about bad sectors.
I ran an HP complete hardware test from a CD that came with my computer. It's self-booting so I didn't need to load to Windows (Which is become increasingly difficult to do). RAM, CPU, and GPU all reported back with-out errors, but once again errors popped up in the hard drive department. I took a picture on my phone, but I'll just type what it said:

Disk 0 Smart Self-Test Short.............
The read element failed
Model: WDC WD5000AAKS-65YGA0 / SN: WD-WCAS82913404 / Rev:12.0
Test ID = HD&12
Error Code: HD521-2
Disc 0 Smart Self-Test Short FAILED
EDIT: Forgot to add that I don't want to run the Western Digital Diagnostics if I don't have too, it's nearly impossible to boot now, at least 30 tries if ever to get in.

Thanks for the reply!
 


Last edited:

Captain Jack

Extraordinary Member
#17
Yup .. That's a green light, backup your data and replace your HDD as soon as you can.
 


#18
Thanks for all your help mate! You've been a huge help. Congrats on the 700 posts btw, anything I can do that will increase your profile REP or whatever this forum uses?
 


Captain Jack

Extraordinary Member
#19
Thanks Mate :) We don't use REP system in this forum. You kind words is are more than enough.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.