Can not connect to a server running Windows 2000 server

Discussion in 'Windows 7 Networking' started by jmerritt, Oct 23, 2009.

  1. jmerritt

    jmerritt New Member

    Joined:
    Oct 23, 2009
    Messages:
    4
    Likes Received:
    0
    I just installed windows 7 Home Premium 64bit yesterday on my laptop. When i am at work i cannot connect to our main server(Windows 2000 server) with the the printers on it. When i try to log on to it, i keep getting login failed wrong username or password. The username does not have a password. Even if i put a password i still cannot login. I am not trying to use remote desktop just going through the network. I have all the workgroups the same. I can also connect to every other computer on the network including machines running win 98.
     
  2. Dan7

    Dan7 New Member

    Joined:
    Oct 23, 2009
    Messages:
    10
    Likes Received:
    0
    Same problem here, but with a Win 2000 machine I use as a server rather than Win 2000 Server.

    Even though it has been fine with all previous windows versions, I have searched around and tried the following:

    1. Checked User/Pass
    2. Use full credentials ie. \\server\user
    3. Removed Homegroup from W7 machine.
    4. Checked Workgroup settings on each machine.
    5. Checked date/time settings on each.
    6. Tried adjusting security policy. You can change this on Win 2000, but not on W7 Home Premium (which I have).

    No luck as yet. The ridiculous thing is that from the Win 2000 machine I can log on to my Win 7 without an issue. Win 2000 can sort out W7, but not vice versa.

    I find it infuriating that MS presents these hurdles with such straightforward functions that have always been fine. With Vista, I spent most of the first day simply trying to move a folder full of files back onto my clean install. It promised to take 142 hours and then only copied a random selection of files.

    Hmmmm. What a waste of time.
     
    #2 Dan7, Oct 23, 2009
    Last edited: Oct 23, 2009
  3. Dan7

    Dan7 New Member

    Joined:
    Oct 23, 2009
    Messages:
    10
    Likes Received:
    0
    Got there in the end. Some combination of adjusting security policy on Win 2000 machine and firewall on Win7 seemed to do the trick.
     
  4. GilV

    GilV New Member

    Joined:
    Oct 26, 2009
    Messages:
    2
    Likes Received:
    0
  5. Dan7

    Dan7 New Member

    Joined:
    Oct 23, 2009
    Messages:
    10
    Likes Received:
    0
    As I said, I had to fix up the security policy. But you cannot get access to this in the Home Premium version, so you have to change it on the Win 2000 machine instead. However, this fix didn't work on its own; meddling with the firewall on the W7 machine is what finally let me through.
    Cheers
    :)
     
  6. amtsalx

    amtsalx New Member

    Joined:
    Oct 26, 2009
    Messages:
    4
    Likes Received:
    0
    I am having the same problem & have Windows 7 Home Premium too. I have disabled the firewall & windows 7 & have turned off the setting to ask for a password to enter the Win 2000 machine but am still being asked for a password in Win 7. Can someone please help! Thanks in advance.
     
  7. Dan7

    Dan7 New Member

    Joined:
    Oct 23, 2009
    Messages:
    10
    Likes Received:
    0
    Not sure from your email, but you do have to change the security policy on the 2000 machine. W7 uses NTLMv2 by default and Home Premium doesn't let you change it. You therefore have to change the one used in 2000.

    On the 2000 machine, go to Administrative tools / Local Security Policy / Local Policies / Security Options / LAN Manager Authentication Level then select 'Send LM & NTLM - use NTLMv2 session security if negotiated'.

    Failing this, try some of the other things in the list above.
    Good luck.
     
  8. amtsalx

    amtsalx New Member

    Joined:
    Oct 26, 2009
    Messages:
    4
    Likes Received:
    0
    I changed the settings on the 2000 machine but the 7 machine is still asking for a username & password. I have the firewall disabled?
     
  9. jmerritt

    jmerritt New Member

    Joined:
    Oct 23, 2009
    Messages:
    4
    Likes Received:
    0
  10. Dan7

    Dan7 New Member

    Joined:
    Oct 23, 2009
    Messages:
    10
    Likes Received:
    0
    Nice one mate.

    My connection dropped again mid-sentence (so to speak) with no apparent updates etc as the cause. Anyway, the registry fix worked a treat. Phew. Copied below....

    Set the following Registry key “HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevelâ€Â￾ to “1â€Â￾.

    If there is no the “LMCompatibilityLevelâ€Â￾ key, please create it as DWord and set the value to 1.

    Thanks to Nicholas Li on the technet site :)
     
  11. stonehands

    stonehands New Member

    Joined:
    Nov 12, 2009
    Messages:
    2
    Likes Received:
    0
    Did not work

    I added the key and did not change anything still gives passowrd error.
    Do you creat a Key then add somthing to the key? Not sure how you guys are adding the value. I have a windows 2000 server. Do I need to do something on it as well? Windows 7 home premium laptop trying to connect to shared folders on server. thanks
     
  12. bizzy67

    bizzy67 New Member

    Joined:
    Jul 20, 2010
    Messages:
    4
    Likes Received:
    0
    Re: Did not work

    So I have Windows 7 Basic and Windows 2000 Advanced Server computers - I can not even FIND them to log in - how do I go about doing that? I'm going crazy right now LOL
     
  13. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Re: Did not work

    bizzy67:
    Hello and welcome to the forums.
    Assuming both machines are plugged into the same switch ports on your router, or a common switch or hub: Check the IP addressing schemes on both computers, using ipconfig /all on both. Determine each machines IP address and make sure they both are on the same subnet. Use the ping command and make sure that you can ping each machine from the other by IP address and then by netbios name. Make sure both machine are in the same workgroup.
    You question doesn't provide a lot of detail, so is the 2000 server acting as a domain controller? If so, I'm not sure that the "Basic" version of Windows 7 can actually join the domain, but as long as the workgroup name on the Win7 machine is the same as the domain name as the server then you may have some success with pass through authentication provided you have a username and password on the 2000 server that is exactly the same as the one you are using to logon to the Windows 7 machine. So if your domain is called mydomain.local then the workgroup name for the Win7 machine should be mydomain
    If the 2000 server is also an AD domain controller, and hosting DNS resolution for your domain, then make sure that the Win7 machine is using it as the primary DNS server.
    On the Win7 machine open the network and sharing center click the link to "Change advanced settings" and adjust them using common sense for what you want to get accomplished.
    Turn on network discovery
    Turn on file and printer sharing
    Public folder sharing.....up to you
    Media streaming.....up to you
    File sharing connections...you may have to dumb it down, not sure, so try 128 bit, if that don't work trying 40-56 bit
    Password protected sharing....up to you
    HomeGroup connections ...use user accounts and password to connect to other computers
    Of course make sure that the "workstation" and "server" service is started and set to automatic
     
  14. bizzy67

    bizzy67 New Member

    Joined:
    Jul 20, 2010
    Messages:
    4
    Likes Received:
    0
    Re: Did not work

    Hi Trouble and thanks for your welcome to the forums :)

    Both computers are connected to a switch. Just replaced an old Dell(XP) with a new HP(Windows7) and it doesn't see the other computer(DELL-Windows2000Advanced Server)

    I went ahead and PINGed the 2 computers and it went through successfully (pinged the ip and the computer names)

    Changed the workgroup name to the same as the server - so now the comp is showing up on the other...

    Problem is logging into the windows 2000 - our username/password isn't correct. We tried logging in w/ the the username/password for both computers and no luck
     
  15. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Re: Did not work

    You still haven't mentioned if this Win2k server is acting as a domain controller unless I just missed it again in re-reading your posts. Anyway
    In the case of a domain controller, try using DomainName\UserName in the username box and see if that works...otherwise
    In the case of a workgroup environment, try using the MachineName\Username in the username box and see what happens.

    This may be an issue with NTLMv2 which Win7 uses out of the box by default and I'm not sure if the Win2k machine does so take a look at this thread regarding the NTLMv2 issues herehttp://windows7forums.com/windows-7-networking/46018-got-rather-nasty-network-problem.html if the other logon method above doesn't do the trick
     

Share This Page

Loading...