Can not remote desktop connect to all computers on network

#1
We are running Windows 2008 Small Business Server and all workstations are Windows 7 Pro. We can remote desktop some of our workstations but others we can't. All of the settings seem to be the same on all of the workstations. The workstations that we can't remote desktop into, we can remote desktop from them to another computer. For test purposes, all firewalls have been turned off. Does anyone have an idea as to why some workstations we can't remote desktop into and others we can? Any ideas would be greatly appreciated.

Chris
 


Trouble

Noob Whisperer
#2
Usually this is a result of change the default RDP listening port to something other than 3389. See attachment and use regedit to check the associated value
 


#3
The value on the workstations that will not accept a remote desktop connect is set to port 3389.
 


Trouble

Noob Whisperer
#4
Do the problem machines belong to a seperate or unique OU and as a result have a different Group Policy applied. Additonally there are local policies on the individual machine that can impact your ability to RD as well.
gpedit.msc
Computer Configuration
Administrative Templates
Windows Components
Remote Desktop Services
Remote Desktop Session Host
Connections
and
Security
 


#5
We are running Windows 2008 Small Business Server and all workstations are Windows 7 Pro. We can remote desktop some of our workstations but others we can't. All of the settings seem to be the same on all of the workstations. The workstations that we can't remote desktop into, we can remote desktop from them to another computer. For test purposes, all firewalls have been turned off. Does anyone have an idea as to why some workstations we can't remote desktop into and others we can? Any ideas would be greatly appreciated.

Chris
Trouble is probably going to be most helpful here, but another thing to check on is any firewall rules in the router that could possibly be affecting what is going on.

I see you've written that all firewalls have been turned off, but I don't know if you mean hardware firewall too, or not. Just thought I'd mention it.
 


#6
To Trouble: all of the entries in there were set to not defined.

to TorrentG, I don't think it is in the router, as we only have 1 router and everything is going through it and some workstations we can remote desktop to and some we can't.
 


#7
I hear that, but it very well could be a directional issue with the firewall. Firewalls can easy allow certain traffic one way while blocking the same exact traffic in another. At the very least, it should be reviewed to rule it either out or the actual culprit.

For a test, you could connect two of these machines together by setting static ips and eliminating the router all together. See if it works like this (obviosuly for machines that weren't working well, previously.)
 


Trouble

Noob Whisperer
#8
Can we assume for the purposes of this discussion that all machines are on the local subnet with private reserved IP address and that you are not attempting to go out and then back in through the router, but rather all RD traffic is being conducted on the local lan and you are using IP address and not hostnames in your attempts to connect?
Additonally can we assume that you or whoever is administering the network is not running Microsoft ISA server on the 2k8 SBS?
Also have you checked the local event viewers on the problem machines to see if there is anything there that might be helpful.
Also can you confirm that the problem machines are unilaterally refusing RD from all other computers on the subnet or just one or two?
 


Trouble

Noob Whisperer
#9
Type mstsc into the search box and hit enter.
Type the ip of one of the problem machines into the name box and click connect
What happens? Typical can't connect to the server for one of the following reasons and list like three reasons or is something else entirely different happening?
 


#10
all of the computers on the network are on the same subnet. when I go to mstsc and type in the ip number of one of the workstations that we can't remote desktop into, it gives the following error: "This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator." Our workstations get their ip number from dhcp server on the Windows 2008 SBS machine. We usually connect to the workstations by their computer name. However, we have some machines that we can't connect to by computer name or ip number. We have tried from several different computers to log into the problem machines and we get the same error message above on all of them.
 


#11
I have a similar problem, but I am sure that it is because the computers I cannot connect to are on a remote VPN network (separate subnet).

I can RDP to those remote computers using Windows/XP, but not using Windows 7. I can RDP to all machines on the local sub-net without issue.

I am sure this must be a simple setting.

Thanks in advance!
 


#12
I have tried everything that has been posted on the thread so far, any other ideas or something to try? I think it is a setting in windows 7. From my workstation, which is running windows 7, I can RDP to the server, which is running SBS 2008, and to workstations running windows xp. However, from my workstation, I can not RDP to any workstation running windows 7. Before we upgraded our workstations to windows 7, we were all running windows xp and I could RDP to every computer on our network. Our router is still the same as it was when we all had XP machines so I am thinking it is something to do with windows 7. Any help or ideas of what to try would be very much appreciated. Thank you.

Chris
 


Last edited:

Trouble

Noob Whisperer
#13
I have a similar problem, but I am sure that it is because the computers I cannot connect to are on a remote VPN network (separate subnet).

I can RDP to those remote computers using Windows/XP, but not using Windows 7. I can RDP to all machines on the local sub-net without issue.

I am sure this must be a simple setting.

Thanks in advance!
Hello and welcome to the forums.
Not sure if this is the issue but it might be worth taking a look see.
Right click your VPN connection and choose properties
Select the Networking tab
Select Internet Protocol Version 4 and click the properties button and then click the Advanced button
Under the IP Settings tab check the box "Use default gateway on remote network"
See if that makes any difference at all
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.