Can't access a network drive - you do not permission to access

Discussion in 'Windows 7 Networking' started by BillyJones, Feb 15, 2011.

  1. BillyJones

    BillyJones New Member

    Joined:
    Feb 15, 2011
    Messages:
    2
    Likes Received:
    0
    I have two Window 7 peers hard wired thru an SMC.
    I'm not using homegroups. I can see the public shares on Peer 1 from Peer 2 and similarly I can see the public shares on Peer 2 from Peer 1. However I can't see drives (my storage drives) on Peer 1 from Peer 2. The opposite is also true. Get the message from the topic line above.

    Why can't I see public shares but not other drives? The workgroup on both peers has the same name. I have shut down my firewall but as expected that had no impact. Everything that is supposed to be on is on - network discovery, file and printer sharing etc. I have set the media drives to share (advanced sharing, permissions) and have even tried the everyone setting. I have disabled passwords.

    This network worked perfectly with XP why won't it work with Win 7 and most importantly why can I see public but not other drives. This obviously not a connection or hardware issue since I can see the the public shares perfectly.
     
    #1 BillyJones, Feb 15, 2011
    Last edited: Feb 15, 2011
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    BillyJones;
    Hello and welcome to the forums.
    In addition to defining share permissions, you also need to define NTFS permissions using the security tab in the properties of the shared folder or file. Additionally you may find it useful to make sure that an identical username and password (with the appropriate permissions) is common (present) on both peers not mandatory as you should still receive a prompt to submit a username and password when accessing a share on one machine from another, it just makes things simpler and may help alleviate some confusion. Without these in common, when prompted for credentials, use the following format
    MachineNameHostingShare\UserNameOnThatMachine
    PasswordForThatUserOnThatMachine
    Keep us posted.
    Randy
     

Share This Page

Loading...