Can't move or delete files on portable USB 2.5" drive

#1
I run Win 7 on a Dell XPS M1530 running on AC power. I attached an Iomega USB 2.5" portable drive and booted up. This drive worked OK when last used with a desktop PC. I wanted to delete unused and old files from the drive, but can't. I also can't transfer them to the laptop. They do open, though.

As an example, I wanted to move a 13 mb PDF from the drive to the laptop Desktop. This is what happens:

A box pops up saying, 'You need Administrator's rights to move this file', so I click Continue > then a box appears headed 'Moving' (with a section of green repeatedly passing through the progress bar field) > then a 'Move File' box appears with the message "Can't read from the source file or disk". Try Again and Cancel buttons are at the bottom.

Certain files can be moved to the laptop, however. I just moved a small .mht file to the laptop just now. I also just tried transferring a folder of miscellaneous files just now. No go.

I need suggestions about this, please. I no longer have the desktop machine, btw, just the laptop.

Thanks.
 


Joe S

Excellent Member
#2
You may need to take ownership of the drive. I don't know that much about it just do a search for instructions.
Joe
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.