Can't wake up from sleep/hibernation

Discussion in 'Windows 7 Help and Support' started by dochalladay32, Mar 11, 2011.

  1. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    I will first say I read the similar threads and none of them applied. Secondly, this is a home build that is nearly a year old with no issues to this point so it's not connected to so-and-so who released a driver update that I know of.

    I want to say 2 days ago, my computer has decided to fail when going to sleep. It is Windows 7, completely updated with no problems to that point. When it falls asleep and I wake it up, the machine starts up and is active, but my monitors and external hard drive are never turned on as they once were and the machine just sits there running with a black screen. I restart, boot back into Windows and it says resume (as if it was in hibernation, but I have hybrid sleep on) and I just get a flashing underscore and no more. I restart once again, it says Windows could not restore the session, I start a new session and all is good again... until the computer falls asleep and the process starts over.

    I have tried turning off hybrid sleep. No good. I have tried using hibernation instead of sleep. Same error. I found online where someone said they had this problem with an ATI card, but once the upgraded the Catalyst Control Center and drivers, they had no problems. That did no good. The only update I've done recenly is Firefox, but I have not seen any other reports of the newest Firefox causing sleep problems. I read where someone had a problem with waking up from sleep mode because of Firefox's memory leaks and they said closing Firefox before putting it to sleep helped. No luck for me.

    It does not matter if I put it to sleep and wake it up immediately or if it goes to sleep and when I get home from work, boot it up. The same thing happens no matter the length of time.

    I have a dual boot with Ubuntu, but that has been on there for months with no errors and Ubuntu will sleep and wake up just fine. There have been no hardware changes or any hardware driver changes other than the video card. I tried rolling back video card drivers to see if there was a difference with no change. My ASRock MB has the most up to date BIOS that has been out for over a year. My video card is a 5770, but like I said, I've tried older and new drivers. I tried the prevx black screen fix with no luck. I saw the Windows hotfix for this problem, but no where did they provide a link to this hotfix so I'm assuming it was downloaded in an update at some point so it is doing no good for me.

    The simple solution is just to shut it down every single time I don't want it on... but that is far from the best solution. But I'm at a loss as to what could be wrong.
     
  2. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    Well, I got it to wake up, but it sure did take a bit. All the items plugged into the main board come on right away, but the peripherals took awhile. This is the first time in a few days that I've gotten it to wake up on it's own, so I don't know if the problem is completely solved, but it showed signs of life at least.

    EDIT: I triggered it by plugging in a flash drive. Certainly odd, but I shouldn't have to plug in a flash drive to get my monitors to kick on.

    Got some more info on it. The machine turns on when I move the mouse, but it stays asleep because my backup never recorded last night. And the only way to get it to come on with the flash drive is if I plug it into my media card reader's USB port, not the front ports of the case. Everything works on the machine once it is on, but only the port on that will trigger Windows to continue waking up... makes no sense what-so-ever.
     
    #2 dochalladay32, Mar 11, 2011
    Last edited: Mar 12, 2011
  3. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    Just seeing if anyone at all here has any clue. I've gotten it now to where it takes exactly 1 minute and 50 seconds to wake up. The power supply works fine, else I think I would see some other failure at some point. I've tried disconnecting the extras to see if that does anything. No luck otherwise.

    Anyone, anyone at all have this problem or heard of it before?
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    There is a utility I try to recommend running to check your system. I suggest shutting down all running programs so as to make the report as simple as possible. When it is done, make note of where the report is saved and you will probably have to copy it to the desktop to open. Some of the comments are common, so look for something that might make sense for your situation. If you want to use the snipping tool to take a picture, then paint to remove any personal information, you can attach it here if you use the paperclip in the advanced reply option.

    Open an Administrative command prompt and type:

    powercfg -energy

    It should take about a minute. If you want to check other items, such as what woke it up last, type powercfg /? and look for that switch.
     
  5. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    May not need to paste. Thanks for the tip on copying it. I ran it before but didn't know I needed to copy it out of system32. But the one error that showed up many times is that USB devices aren't entering suspend. All of my USB devices. Now I know this is normal if they are used to wake up the system, but the keyboard and mouse should be the only USB devices that are allowed to wake it up. I can try to paste the report later, but nothing else seems out of the ordinary. Just warnings about my monitor going off after 20 minutes rather than 10 and that I have processors that use too much power.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I get those USB error messages also, and they decrease if I unplug my gaming controller, but my system sleeps fine.

    The comment about plugging in a flash drive seems a little strange, but I do not remember ever having done that. You might check Device Manager and look at the properties for the USB Root Hubs under the Power Management tab and see if any of them are set to allow them to wake the computer.

    You say you do not know of any updates, did you get the SP1 update? I don't know that it causes any problems, it did not for me, but different systems might behave differently.
     
  7. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    I took a look and for USB devices that do have the power menu, the wake option is grayed out.

    And I had the problem before SP1 came out. I installed SP1 with no issues but the problem hasn't improved or worsened.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    All I might suggest is to unplug anything you can from your system and test. External devices, like flash drives might cause problems. Also using msconfig to keep some programs from starting up might allow you to test, but problems here should have shown up in the powercfg test.

    You might check the event viewer to see if any errors or warnings show up consistently.

    Try changing your power scheme and set it to something other than it is now. After a period of time you may be able to go back, if it helps at all.

    Do you use the Ubuntu boot loader or Win 7? You might open another Admin Command Prompt and type bcdedit to check the Windows boot loader. It should look something like the attachment. If you think you might be having a problem there, you can download EasyBCD version 2 or higher, and have it set up your dual boot.

    If you still cannot find it, I would try to get Win 7 working normally which might mean doing a startup recovery on it and loosing temporarily the Ubuntu boot option. I can't really think of anything else to try right now.
     

    Attached Files:

    #8 Saltgrass, Mar 16, 2011
    Last edited: Mar 16, 2011
  9. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    I restored the original boot record, but no luck. Needed longer to come out of sleep, but same issue in general. Too long to wake up.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I added some things to my original response, did you see those?
     
  11. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    I unplugged things piece by piece with no luck. Even went back to onboard video which I had never done before, but same problem. Took about 6 minutes to wake up. If it is hardware, it is processor, motherboard, or PSU and in that case, I'll have to live with it. I've checked the hard drives and they are all good and I doubt the DVD drive is causing it.

    I did see a device control error for hard drives. But it is always a random hard drive number. But I've run scans and did S.M.A.R.T. tests with nothing showing up. Nothing else shows up under system errors.

    I can try changing the power scheme. It certainly couldn't hurt.
     
  12. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I was wondering, how much RAM do you have and how much space open on your hard drive?
     
  13. dochalladay32

    dochalladay32 New Member

    Joined:
    Mar 11, 2011
    Messages:
    22
    Likes Received:
    0
    4 GB of ram and I have one disk with 315 GB free of 465 that I use for backups. Then I have 690 GB free of 800; rest is Linux. Then on my external I have 400 free of 930.
     

Share This Page

Loading...