Charms Bar Stuck on Left Screen in Windows 8.1 using Dual Monitors / Extended Desktop

Discussion in 'Windows 8 Help and Support' started by Mijin, Jul 12, 2014.

  1. Mijin

    Mijin Member

    Joined:
    Jul 12, 2014
    Messages:
    4
    Likes Received:
    0
    Using dual monitors set to extended in Windows 8.0 the charms bar would extend to right side of the rightmost screen (right most part of the extended desktop) this was great because it kept it well out of my way. In Windows 8.1 it seems that no matter what I do it is stuck on the screen that happens to be my main screen. I've even tried to designate the other monitor as the main screen, but to my dismay the charms bar stubbornly stays put on the right side of my larger screen. I've tried to find a way to delete it all together in the registry, but I've been unsuccessful. I did find a way to disable it from activating when you move your mouse to it, multiple ways actually, but the dormant charms bar still leaves a black bar taking up a portion of my screen on the right side. It also catches up the mouse when I drag my mouse from one screen to the next causing a short delay.

    Is there anyway to move the charms bar to my other screen, the far right side of my extended desktop, or if not is there a way to remove the charms bar completely?
     
  2. Mijin

    Mijin Member

    Joined:
    Jul 12, 2014
    Messages:
    4
    Likes Received:
    0
    I found a solution by editing a registry file to prevent my mouse from sticking, but the black box from the dormant charms bar is still clogging up the right side of my screen
     
  3. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,796
    Likes Received:
    1,563
    Hi,
    you can disable the Charms bar by right clicking on the Task Bar, choose properties and then Navigation (along the top). You'll see a checkbox at the top enabling the Charms Bar, you simply need to uncheck it.
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Is it possible to switch the ID on monitors so the one with the taskbar is on the right?
    I.e. switch which monitor is identified and monitor one and two.
     
  5. Mijin

    Mijin Member

    Joined:
    Jul 12, 2014
    Messages:
    4
    Likes Received:
    0
    I tried to check that out too, and while the option is there to disable the activation of charms via pointing mouse in the upperr-right corner, there is no option to disable it.

    [​IMG]

    I tried that also, and oddly enough regardless of which screen I designate as the main screen, even after restart, the charms bar does not move, ironically every single other thing does.

    My main concern was the mouse getting stuck when I move my mouse from the left screen to the right as it hits the dormant charm, however I was able to overcome this by changing MouseCornerClipLength in the registry from 6 to 0. I've also disabled it from activating when the mouse touches it. The only problem that still remains is the black bar on the right side of my screen from the non active charm bar.
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,796
    Likes Received:
    1,563

Share This Page

Loading...