Clean Install with sil3132?

Discussion in 'Windows 7 Installation' started by Lance, Jan 24, 2009.

  1. Lance

    Lance New Member

    Joined:
    Jan 24, 2009
    Messages:
    2
    Likes Received:
    0
    I cant seem to get 7000 to recognize my driveson installation. (no drives found). what driver should i use?
    I have tried raid, lagacy ide, native ide. and all the drivers on the cd and on the websites.

    Vista works fine.

    WD drives.
    DFI 790FX with SIL3132

    Any help would be apreciated...thnks

    nvm.. .got it..
     
    #1 Lance, Jan 24, 2009
    Last edited: Jan 24, 2009
  2. TimE

    TimE New Member

    Joined:
    Nov 2, 2009
    Messages:
    2
    Likes Received:
    0
    I had a problem doing a clean install of Windows 7 with my motherboard, which also contains a sil3132 SATA controller.

    Windows 7 could not see the controller, and therefore not the drives. I asked ABIT for help, but as yet have received none.

    I solved this by dowloading the latest driver from the Silicon Image website. I was installing the 64-bit version.

    This driver contains two directories, one called AMD64 and the other IA64. When I selected IA64 (Intel??) Windows could see no valid drivers, but when I tried (in desperation) the AMD64 directory it seemed to find the driver I needed ???

    My system is Intel, not AMD ... so I can only guess that Silicon Images have put the drivers under the wrong categories.

    Using this driver I successfully installed Windows 7
     
  3. paul45

    paul45 New Member

    Joined:
    Nov 6, 2009
    Messages:
    2
    Likes Received:
    0
    The method above I tried did not work for me, but something else did, maybe it will be of some use to people. I had to exit out of these install screens until I got back to the first screen that says "Install" at the top or "Repair" near the bottom. I selected "Repair". Windows will scan your system, in my case it found errors in my existing Vista installation - I just canceled out of that screen, electing not to repair. Then you have a screen where a button on the bottom left says "load drivers." I selected that option and then navigated to my USB drive and loaded the drivers for the Sil3132 card that I download directly from SiliconImage website. Then I exited out of this "Repair" area back to the main screen where I chose "Install". Then it worked, no more prompting to load drivers that Windows can't recognize. Seems like it is a bug with the installation or something, but just glad to have gotten it to work - after quite a bit of frustration!
     
  4. Luca Colonnese

    Luca Colonnese New Member

    Joined:
    Aug 31, 2012
    Messages:
    2
    Likes Received:
    0
    Hey, sorry for the intrusion. I was having the exact issue as the OP and later realized that my motherboard BIOS settings were on IDE/LEGACY for the SATA drives, make sure they're in AHCI or Windows 7 will not detect your RAID properly. Once I put the BIOS to AHCI (under integrated devices, my mobo is a Gigabyte) it immediately detected the RAID after a reboot.

    It also loads the Windows 7 installer 100 times faster looool...
     

Share This Page

Loading...