Desktop No Longer Shuts Down.

Discussion in 'Windows 7 Help and Support' started by Elmer, Oct 16, 2011.

  1. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    This started, that I noticed, maybe four weeks ago. I select shutdown from the start menu. Desktop starts closing down. Get the waiting for programs screen. Monitor blacks out, All fans stop. Silence.

    Sounds good, unless I move the mouse, then everything starts up again. It hasn't actually shutdown, it's more like sleep mode.

    The only ways to shut down properly is to hold the start button down on the box or send to sleep and mains power off (on the PSU).
    To be honest, neither is a preferred way I like to shut down my PC. Apart from anything else I get a lot of "didn't shut down properly" screens with either method, plus I give the Step-Daughter major ear grief for using the power off button to shut down!

    Any ideas?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I suppose the same thing happens if you use Alt + F4? Just wondering if your power button on the start menu has gotten misdirected.
     
  3. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    I did make a new shutdown shortcut a while back for my desktop which I think I've tried, with no success. I'll try your suggestion.

    Watch this space!!
     
  4. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Well my desktop shutdown shortcut and the Alt+F4 are having the same result, so no joy. :(

    I did get re-educated on Alt+F4 though, so some joy! :)
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You seem to download many little utilities. Could one of those be causing a problem?

    Multimedia operations might effect your system behavior as far as power options..

    How about safe mode shutdown?

    Edit: I was looking at the shutdown command in the Admin Command prompt, and at the bottom after a shutdown /? it seems like a listing of shutdowns accomplished and why. Maybe something there would give you some guidance.
     
    #5 Saltgrass, Oct 16, 2011
    Last edited: Oct 16, 2011
  6. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Moi? :)
    Wherever possible I try to get the portable versions so they don't actually install, but could possibly be something, somewhere.

    However, I think that's negated by the fact that shutting down from Safe Mode is giving exactly the same (bad) result.
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I was looking through the registry and saw a .dll file that seems to be related to the system shutdown. Don't know for sure, but maybe your situation is related to your ACPI setup. The .dll is powrprof.dll which I will assume is a system file and can be replaced.

    If nothing else, maybe check for an update or reinstall of the ACPI driver.
     
  8. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Only took a month and a half but.....

    While my 80gb recovery hdd was empty I thought I'd install 7 on there to see if the issue still occurs on a totally empty system.

    It does :(.
     
    #8 Elmer, Nov 28, 2011
    Last edited: Nov 28, 2011
  9. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    Elmer, not sure if this will make a difference, and perhaps you already do it, but I have shortcuts on my desktop (one of which is Shutdown). Right click an empty space on the desktop and select New, Shortcut. In the box that appears type, or cut and paste:

    C:\Windows\System32\shutdown.exe -s -t 00

    The next box allows you to name the Shortcut. Click ok and there it is:

    shutdown shortcut.

    The other Shortcuts are as follows:

    Restart - C:\Windows\System32\shutdown.exe -r -t 00

    Sleep - C:\Windows\System32\rundll32.exe powrprof.dll,SetSuspendState 0,1,0

    Logoff - C:\Windows\System32\logoff.exe

    I hope these help someone, even if they do not help you.
     
    #9 Medico, Nov 28, 2011
    Last edited: Nov 28, 2011
  10. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Well After all that, trawling through my bios I found Power up from mouse & Power up from keyboard, both enabled! Not in the "handbook" though!

    I feel really stoopid now, not as bad as not being able to get directx in though!! :D :D :D
     
    2 people like this.
  11. nmsuk

    nmsuk Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Sep 7, 2009
    Messages:
    2,695
    Likes Received:
    194
    This will teach you Kev, never read the book of lies (Manual) :D
     
    1 person likes this.
  12. computerrepairi

    computerrepairi New Member

    Joined:
    Nov 24, 2011
    Messages:
    20
    Likes Received:
    0
    I think there is registry problem try to repair your registry or try to shut down your computer from the taskmanager or creat a short on the desktop or try to shut down it from cmd.Try this all methods.
     

Share This Page

Loading...