Windows 10 Disable display scaling on high dpi settings...

Discussion in 'Windows 10 Help and Support' started by Sankalp, Aug 22, 2016.

  1. Sankalp

    Sankalp Member

    Joined:
    Jul 18, 2016
    Messages:
    71
    Likes Received:
    0
    Very irritating issue here. I tried running a game "Assassin's creed:Syndicate" on my Asus ROG G551VW at a resolution of 1600x900 and it runs on partial screen even when I have fullscreen option checked. It will only occupy full screen if I run the game in 3840x2160 resolution but that's not feasible. Too much lag...unplayable.

    I have 3840x2160 native resolution. I realized that problem lies in display dpi settings in compatibility option.

    See the images:

    Game not running on full screen:
    [​IMG]

    Full screen option is checked as follows::
    [​IMG]

    I realized that "Disable display scaling on high dpi settings" was checked and I needed to uncheck it. So I did. The game ran on full screen for some times...opening credits and all..but then after that returned back to old stage. Then when I quit the game and check settings again, that thing was checked by itself! Windows did that automatically.
    [​IMG]

    Then I changed my native resolution to 1600x900 and game ran on full screen. But then I thought if it was glitch in the game or my laptop. So I went to my neighbor in my college hostel who owns lenovo y50 with 1920x1080 native resolution. He ran the game and it opened in full screen on 1600x900. I wondered how? I soon realized by checking that "Disable display scaling on high dpi settings" remained unchecked on his machine and windows was not automatically checking it.

    So I want to know how can I uncheck "Disable display scaling on high dpi settings" so that windows can't automatically check it again ? Also if there is any other solution please do tell. Thanks in advanced...

    Edit: If I posted in the wrong section please do move it. Again sorry for inconvenience..
     
  2. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,389
    Likes Received:
    360
    I also have a 4k screen and the games I play for the most part work fine since directx will scale them down.
     
  3. Sankalp

    Sankalp Member

    Joined:
    Jul 18, 2016
    Messages:
    71
    Likes Received:
    0
    Does your laptop also checks "Disable display scaling on high dpi settings" automatically as long as the application you're running is dpi aware ?
    I need to uncheck the setting in my game but the system won't let me. Please help.
     
  4. Sankalp

    Sankalp Member

    Joined:
    Jul 18, 2016
    Messages:
    71
    Likes Received:
    0
    I solved my problem. This is what I did:
    I created gamename.exe.manifest file with the code :

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <dependency>
    <dependentAssembly>
    <assemblyIdentity
    type="win32"
    name="Microsoft.Windows.Common-Controls"
    version="6.0.0.0" processorArchitecture="*"
    publicKeyToken="6595b64144ccf1df"
    language="*">
    </assemblyIdentity>
    </dependentAssembly>
    </dependency>

    <dependency>
    <dependentAssembly>
    <assemblyIdentity
    type="win32"
    name="Microsoft.VC90.CRT"
    version="9.0.21022.8"
    processorArchitecture="amd64"
    publicKeyToken="1fc8b3b9a1e18e3b">
    </assemblyIdentity>
    </dependentAssembly>
    </dependency>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
    <security>
    <requestedPrivileges>
    <requestedExecutionLevel
    level="asInvoker"
    uiAccess="false"/>
    </requestedPrivileges>
    </security>
    </trustInfo>

    <asmv3:application>
    <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
    <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>
    </asmv3:windowsSettings>
    </asmv3:application>

    </assembly>

    I saved that file in game install dir...
    Then I ran regedit and went to Hkey local machine....sideby and created a file dword 32 bit for external manifest and set that to decimal 1. Then unchecked that "Disable display scaling on high dpi settings" and ran the game successfully...
     

Share This Page

Loading...