Disable Mouse Wake up

Discussion in 'Windows 7 Help and Support' started by xcess, Jan 11, 2010.

  1. xcess

    xcess New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    Symptom:

    mouse activity persistently wakes up windows 7 pc, even with "Allow this device to wake the computer" unchecked on "HID-compliant mouse"

    Attempted methods for resolution:

    -Unchecked "Allow this device to wake the computer" on "HID-compliant mouse"
    -checked powercfg -devicequery wake_armed, mouse was not listed
    -checked last wake device after mouse wake: It shows: "USB Root Hub"
    -all "USB Root Hub" has "Allow this device to wake the computer" check box greyed out
    -checked BIOS settings: wake on PS/2 Mouse / Keyboard is disabled

    Notes:
    Previously, with Vista OS installed on this computer and "Allow this device to wake the computer" unchecked on "HID-compliant mouse", the mouse did not wake the PC, performing as expected. Before the upgrade to Windows 7, a BIOS update was performed and then Windows 7 was installed.

    Question:

    How do I solve this problem to stop my mouse from waking up my computer?
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Hmm...I'm just wondering if it's your router thats at fault here.. See if unchecking 'allow this device to wake the computer' helps any..
     
  3. xcess

    xcess New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    appreciate the response, however, if it is the router that is at fault, then how does it explain the pc waking up at precisely the same time the mouse is moved?
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Right..gotcha. It was just a shot in the dark really.. Have you tried using a different USB port as this can make a difference..
     
  5. xcess

    xcess New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    update: this problem can arise with two Logitech mice called Logitech Anywhere Mouse MX and Logitech Performance MX.

    Even when using generic windows 7 drivers with Wake disabled, these mice will cause a computer to resume/wake on mouse activity.

    This is a known issue at Logitech.

    Reference: Performance MX + Sleep Mode Wakeup - Logitech Forums
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Much thanks for the update..
     
  7. patcoghm

    patcoghm New Member

    Joined:
    Nov 11, 2010
    Messages:
    2
    Likes Received:
    0
    This answer fixed the mouse movement waking the computer from sleep with the laptop lid shut with Logitech Mouse M505 Unifying.

    In windows 7, click "Start" menu, in the search entry area (one line up from the START button), type "Device Manager". In the results will be Device Manager and most likley it will be at the top of found choices. Click Device Manager and it will open a window to the Device Manager.

    In the Device Manager window, select "Keyboards", select "HID Keyboard Device", open "Power Management", UNCHECK "Allow this device to wake the computer". I had 2 "HID Keyboard Device entries so I UNCHECKED the setting in both.

    Then select "Mice and other pointing devices", select "HID-compliant mouse", open "Power Management", UNCHECK "Allow this device to wake the computer". I had 3 "HID-compliant mouse" entries, 2 had the power managment settings tab and I UNCHECKED the setting in both. ALSO located under "Mice and other pointing devices", select "Logitech HID-compliant Unifying mouse", open "Power Management", UNCHECK "Allow this device to wake the computer"

    This is the solution and works for Laptops that are set to sleep when the lid is closed. The mouse can now be moved buttons pushed and the computer still stays in the Sleep mode. When the Lid is opened it wakes the computer from sleep. If you leave the lid open and put the computer into sleep, it can be wakened by the touch pad, power button and keyboard keys.

    BOTH keyboard and Mouse settings need to be UNCHECKED to disable "Allow this device to wake the computer"
     
  8. RockyMM

    RockyMM New Member

    Joined:
    Dec 11, 2012
    Messages:
    2
    Likes Received:
    0
    I just installed Windows 8 after Windows Vista and I remember that I used powercfg tool to basically achieve the same thing, but I forgot exactly how and what options I have used. This is much easier. Thank you for an excellent post! :) :thumbs_up:
     
  9. beedaan

    beedaan New Member

    Joined:
    Apr 15, 2013
    Messages:
    2
    Likes Received:
    0
    Thank you so much! This was driving me crazy!!
     
  10. FrankXX1234

    FrankXX1234 New Member

    Joined:
    Aug 15, 2013
    Messages:
    1
    Likes Received:
    0
    Thanks for your post, fixed my problem
     
  11. mapletrail

    mapletrail New Member

    Joined:
    Aug 27, 2013
    Messages:
    1
    Likes Received:
    0
    Thank you for pointing out the keyboard connection.
    I have a Logitech M510 wireless USB (mini stub) mouse but a standard keyboard. After previously disabling everything BUT the keyboard, mouse movement still ended sleep mode.
    I then disabled both the (nonexistent) HID & actual PS2 keyboards and neither mouse or keyboard would cause wake up.
    I re-enabled the PS2 keyboard to get the convenience I desired.
     

Share This Page

Loading...