Disable Network Connection Properties

Josh

New Member
#1
Need some help with this problem and after much Googling (an awful verb) i cannot find an answer.
I'm trying to stop users from changing the Properties of Network Connections - in particular the IP Address. Using Group Policy editor i can set the relevant policies to 'Enable' and in Win XP this works perfect, however in Win 7 it doesn't work. Well for 'Standard Users' it does but not for 'Administrators'. I have set "Enable Windows 2000 Network Connections settings for Administrators" to Enable but in Win 7 this has no effect and Administrators can change the properties.:confused:

Is this a known issue or is this a policy that has no effect in Win 7?

Any help much apprieciated.
 


Trouble

Noob Whisperer
#2
Josh:
I have also been trying to get this to work, without success, so unless we're both doing something wrong, I would guess that you can't make this work sufficiently to impact the members of the local administrators group. What I have done here is moved those particular users into the "Power Users" groups (Win7 maintained this group for backwards compatability) this still lets them do most stuff but without an administrators account and password they won't be able to change IP address or anything else in the network connection properties. Don't know if this will work for you, it may be too restrictive in other areas.
 


#3
Have you guys tried to create.....go to local group policy editor>security settings>and right click on IP security policies...and create IP policy....see if that works
 


Josh

New Member
#4
OO-ER Missus!

Trouble,
I thought about that but i'm not sure if that restricts too much. Will change users in the Computer Management Console and have a toy around. Do you know if there is a list of restrictions for Power Users that i can read through? (Don't answer that i've found it - opened my mouth rather than using my eyes and brain!!)

Kevin Hi,
I am quite an experienced PC operator but not quite that experienced! Not sure what to do when i create the policy, however I did try and I get a warning that this only works on 2000 & XP and also get a warning that the 'default response' does not work on Vista.:confused:

When i try to add a Rule the actions are;
IP tunneling attributes
Authentication methods
Filter Actions
:(

I was kind of hoping for an object or property to disable the 'Properties' of the Network Connection - nothing in lfe is easy eh :D


Can you advise me of a step by step procedure to add the IP policy etc?

Many thanks in advance
 


Last edited:

Josh

New Member
#5
Power Users

Power Users cannot install software so that will be a bit of a non-starter. I could change this under the Security Settings...Local Policies...User Rights etc but that's a lot of work if there is a simple answer to the Network Connection properties issue.
 


Trouble

Noob Whisperer
#6
Power Users cannot install software so that will be a bit of a non-starter. I could change this under the Security Settings...Local Policies...User Rights etc but that's a lot of work if there is a simple answer to the Network Connection properties issue.
I wasn't able to find one....at least not yet. If you have any luck resolving this please let me know...either post back here or PM me....I would certainly appreciate it.
 


Josh

New Member
#7
I wasn't able to find one....at least not yet. If you have any luck resolving this please let me know...either post back here or PM me....I would certainly appreciate it.
I certainly will and er um ....... Ditto !!
 


reghakr

Essential Member
#8
I might have a registry script that will remove Network Connections from Control Panel as well as the entries in Internet Explorer.

Hang on, I';ll have to test
 


reghakr

Essential Member
#10
i have a script to disable the complete control panel

Are you also looking at restrictions in Internet Exploder also?

Gotta go, be back in about 45 minutes.
 


Last edited:

Josh

New Member
#11
How to delete network connections in Windows 7?
i have a script to disable the complete control panel
Are you also looking at restrictions in Internet Exploder also?
If you read my first post........never mind here you go;

I want to stop users (Standard and Admins) accessing the "Properties" of any "Network Connection" in Windows 7. This will stop the users changing the IP address. In Win XP you can change the various Policies in the Group Policy Editor and in particular the "Enable Windows 2000 Network Connections settings for Administrators" which enforces the policies for administrators as well as normal users. When you carry out these changes the "Properties" of a "Network Connection" (right click) is grayed out in Win XP. In Win 7 you can change the (same) various Policies in the Group Policy Editor, but even if you change "Enable Windows 2000 Network Connections settings for Administrators" to "Enable", the "Properties" (right click) of a "Network Connection" is still accessible by Admins.
Since Standard Users can be restricted it must be possible to restrict Admins - surely?
 


reghakr

Essential Member
#12
I tried with the Network Connections applet tostop users (Standard and Admins) accessing the "Properties" of any "Network Connection"

If the Network Connections applet was disabled, they wouldn't be a able to get into properties, correct?
 


Josh

New Member
#13
If the Network Connections applet was disabled, they wouldn't be a able to get into properties, correct?
Disable the applet - Yup i think that would do it :) Why do you have something?
 


reghakr

Essential Member
#14
As I stated, I can't remove the Network k Connections from Control panel, but I can Hide the entire Control panel.
 


#15
Gotta go, be back in about 45 minutes.
Speaking of time.... when you get back, can you figure out why so many members here, including yourself, show the 365 day award, when they have joined this year? No matter what day someone joins THIS YEAR, the math is funny if they have been here 365 days already... unless this year has 13 months???
 


reghakr

Essential Member
#16
Now how could I gigure that out?

I'm no Admin
 


Trouble

Noob Whisperer
#17
It's obviously a problem with the Ancient Mayan Calendar that the site is using and Christmas coming early to RegHakr
 


#18
Or the programmer is a victim of public education.
 


#19
No Joy

It doesn't look like we are going to get a solution to this :frown:. I will continue looking and tweaking - if i get a result i will post here.
 


#20
Possible Reason

Had a chat with a Microsoft Technical Support chappie who had access to my machine over the internet. After an hour or so he reported that it is strange as it works on their machines - just one difference they are running Win 7 Ultimate. I have tried on 4 machines running Win 7 Professional and it does not work.:(
If anyone is running Ultimate can they please check this. I'm hoping to receive an Ultimate machine next week so will confirm this then. In the meantime I will be receiving a call on Monday from another guy at MS after they have passed this issue to their development team for analysis.

I will report back late Monday, hopefully with a resolution :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.