DVD+/-R/CD+/-R will not read or write

Discussion in 'Windows 7 Hardware' started by alphaamanitin, Feb 14, 2011.

  1. alphaamanitin

    alphaamanitin New Member

    Joined:
    Feb 14, 2011
    Messages:
    18
    Likes Received:
    0
    [SOLVED] DVD+/-R/CD+/-R will not read or write

    Hey guys,

    So I built a Windows machine recently (~8 months ago). It has Windows 7 32 bit Professional Installed on it. Twice now I have had the DVD device die. The first time it was a Sony, no a Lite-On iHAS242. The first time I thought oh well, dead DVD drive and bought another one, but now it has died. Both died after about 4 months.

    Here are the details of the problem. It was running fine, watching DVDs, turned it off and the next time I went to play a DVD it was dead, this was about two days later. It is still in My Computer, the drive will recognize media. If I put a DVD in it will display the title of the DVD and how much memory of the DVD is free, it will even open DVD and CD to display what is inside. However, if I try to play a DVD or use whatever is on the DVD or CD the program attempting to run the DVD/CD content freezes. If it is a Microsoft program the whole computer freezes.

    Thins I did to try to fix it.

    First thing I did was uninstall the device in device manager and rebooted. Didn't work. Physically disconnected the DVD/CD-RW and waited a few minutes. Plugged it back in, same problem. Deleted all the registry values associated with the DVD/CD-RW drive, uninstalled the drive rebooted, same issue. Replaced the drive with my old Sony, that I had the same issue on 4 months previous, same issue.

    I tried the Fix It program available from Microsoft, but that would not run. Said that my certificates were not okay and would not run. Gave up on trying to solve that issue and the instructions I found did not make sense to me. Here is a link to the steps I tried to use as I had the same issue of the original poster:
    Problems installing fixit - invalid certificate

    Should also mention that the first time I replaced the drive I replaced the SATA cable as well, so it should not be a faulty cable. Tonight Iwill try booting a live Ubuntu and see if Ubuntu has the same issues.

    Thanks,

    AlphaA
     
    #1 alphaamanitin, Feb 14, 2011
    Last edited: Feb 17, 2011
  2. alphaamanitin

    alphaamanitin New Member

    Joined:
    Feb 14, 2011
    Messages:
    18
    Likes Received:
    0
    BUMP with new info.

    Have solved issue. Uninstalled everything I can think of that had to do with the DVD drive. I removed VLC player, ImgBurn, and VirtualCloneDrive. These where things that had been used recently and VLC player and ImgBurn had been updated. Well VLC wanted to update and I chose to do it later instead of updating it because I wanted to watch a movie. Anyway, after uninstalling all of those I uninstalled the drive through Device Manager. I then deleted all the registry values as I had done before. Rebooted, tried a DVD with KMPlayer and it worked. Reinstalled everything but VirtualCloneDrive and everything still worked. I suspect the issue was with VLC wanting to update and not getting updated.

    AlphaA
     

Share This Page

Loading...