Dynamic Disk Invalid

#41
It works!
I'm another person who has just registered to say a massive THANKYOU to bdonk.
 


#42
#43
I'm also going to add my gratitude to the OP. Works perfectly.

The only other piece of advice is that on running HxD I couldn't see my problem drive, but doing a 'run as administrator' solved that straight away.
 


#44
I don’t know if some1 is still going read this but i have a question…

My 02 column does not containt a “42” of a “07” in the 1A0 – 1f0 range…
It shows “EE” at the 1c0 section. what does this meen? Am i screwed?

The disk just stopped working out of nothing, i don’t even know if it was dynamic of basic… all i know is that there were 2 partitions and now it says dynamic, invalid and i can’t “activate” it.
 


#45
I did not get a comment but in case someone has similar issue with EE I bit the bullet replaced with 07 and bingo all OK.
But could not save data as could only do a format which was not an issue as all files on the HDD had been backed up.
So now have reinstalled and back to normal.
Trust helps someone.
HEY!
Even I have "EE" at 1C2. What do you mean by "But could not save data..." ?
My hard drive has really, really important data of 250GB approx. I don't have an external hard drive or something where I can keep my files.
Is it absolutely safe to type "07" at "EE" in 1C2?
Are you sure doing this would:\
1) Convert the disk from dynamic to basic.
2) Not lose any data at all.
3) Not arise the problem of invalid disk or something like that
?
I don’t know if some1 is still going read this but i have a question…

My 02 column does not containt a “42” of a “07” in the 1A0 – 1f0 range…
It shows “EE” at the 1c0 section. what does this meen? Am i screwed?

The disk just stopped working out of nothing, i don’t even know if it was dynamic of basic… all i know is that there were 2 partitions and now it says dynamic, invalid and i can’t “activate” it.
Since this thread comes up a lot when searching for any "quick fix" for changing a dynamic drive back to a basic one, I wanted to address the problem these three users had (excluding myself), which I think we will see a lot as time goes by.

First, I want to say that if you encounter a EE/EF at 1C2 you are screwed in regards to HEX editors, you either have to fix your drive the old fashioned way (use an OS that supports dynamic drive, back up, repartition drive to basic and never EVER let some OS change that drive to dynamic again), or look into drive repair tools – of which there are many, and I have tried exactly none.

Second, if you encounter anything other than 42/07/EE/EF; look at this table[1], which lists all different hex codes.

Next; I want to say why, since accepting something without a reason is something that I personally don't like:
Your drive was originally partitioned using GTP – a partition table that support drives over 2 TB in size. Now, since this would mean that older OSes (using the old Master Boot Record (MBR) to now what the drive was) would think that this new drive was unpartitioned, the risk of overwriting/deleting/wreaking havoc on your drive would be immence, the GPT have a "protective MBR" on top which states that this drive uses GPT, hence the EE/EF (Windows vs. Intel code). When an old OS reads the MBR and finds EE, it will know that this drive is partitioned, and therefor shouldn't do anything with it (but you still wouldn't be able to use it).

Now, why couldn't you just find the new place where "07" should be represented (GPT has to know what your drive is, just as with MBR)? This is because of an added layer of security: The GPT header has a checksum, which lets it know if anything in the header is broken, and it has a backup header just for this which can be copied by use of drive recovery software so that you wont lose all your data. This means that if you change "42" to "07" in a hex editor the checksums wont match, and your drive will be rendered invalid also in OSes which supports dynamic drives. Ie.: Something that was meant to help us now stops us from repairing our drives (although, this was Windows' fault to begin with, and not your drive system).

Wiki article on GUID Partition Table Structure[2]​

On to my own problem ... I guess I will have to find somewhere to temporarily store 4 odd TB of data to get my basic drives back ... hope this helps, even though it's a year since the earliest EE problem (only four months since the last though :)) ...

Since this is my first post, I can't post links. Therefore (these are both English Wikipedia-pages):
[1]/wiki/Partition_type#List_of_partition_IDs
[2]/wiki/GUID_Partition_Table

/Signing off/
 


Last edited:
#46
i had 1TB disk which i was about to throw away, then stumbled upon this thread, i have just logged it to say thanks to bdonk, you are excellent and simple narration helped many here i can see, i must recommend you for MVP
 


Stef

New Member
#47
Also wanted to post thanks! I had the invalid dynamic drive in my USB dock. HxD allowed me to edit it would issues. Rescanning in Computer Management -> Storage -> Disk Management showed the proper drive - but just in case I popped it out of the dock and popped it back in.

Worked like a charm!
 


#48
Diskpart showing my drive as invalid. So I'm here through googling. While I'm going to save the hex file after changing 42 to 07, there is an error message saying "The media is write protected". So anyone, please help me, what to do next?
Thanks in advance.
 


Gerry18517

Well-Known Member
#49
FANTASTIC!!!!

I had two older 500 gig SATA drives that I used with Windows 2000, when that system died, CPU gave up the ghost, I got a Dell from my son with Windows 7 on it, I cursed Windows 7, and still do.
Then one of the 500 gig SATA was failing I moved all the data to the remaining 500 gig drive and removed the failing one just as it failed. Then Windows 7 would forget the good 500 gig SATA drive. I would get it back after some work, but today it defied all my efforts.

That is until I found your post.

FANTASTIC, I now have the drive back and will transfer it all to a 1 terabyte drive that's on the way from Amazon.

Your "fix" was a life saver as some of the data on that drive goes way back to when I was using Windows 3.1 and even some text files from a TI/99-4a. Yes I attempted to back it up to an external terabyte drive, but confounded by backups stopping when the system would go to sleep and worried that it would fail in the 9+ hour, (estimated via USB back-up time), I moved the 143 GB, 478,936 Files and 10,163 folders to the good 500 gig drive. (I gotta seriously review those files).

HUGE THANKS!!!

Gerry
 


#50
Thanks bdonk, what a great tip, 7 years on and still helping. Brilliant. :)
 


bdonk

Honorable Member
#51
Gee whiz guys
 


RoelV

New Member
#52
Another one that registered to 1) give thanks, 2) tell you all what I had to do.

A) I too saw the said "This operation is not allowed on the invalid disk pack. " in Windows 10 Virtual Disk Manager after moving a HDD out of another machine and inserting it into a USB enclosure
B) I downloaded HxD as suggested, did Extras > Open Disk > untick 'Open as read only' > Selected the right physical disk
C) Took a while to realize where location 1C2 is... :) You have to go about 29 rows down and then 3 cells to the right. Click on the "42" there and you should see (bottom left) the location (named "Offset") as 1C2. Changed that 42 to 07 and CTRL+S (i.e. saved)
D) Turned external USB power off, back on
E) Now disk showed with drive letter in Virtual Disk Manager but... as RAW, and when going to the assigned drive letter Windows asked if I wanted to format it (WARNING: Click cancel/close the box offcourse here :)). Clicked cancel and downloaded Testdisk 7.1 as another user suggested (a free open source program)
F) Basically did a scan and got it to write out the partition it found. It said I had to reboot. I figured I could just turn off/on the USB enclosure.
G) Turned off/on the USB enclosure.
H) Disk is available, drive letter assigned, data is visible.

WOOOHOOO - Thank you guys!
Thanks be to God also!
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#53
Thank you and hopefully this may be of use to other users.
 


#54
Another one that registered to 1) give thanks, 2) tell you all what I had to do.

A) I too saw the said "This operation is not allowed on the invalid disk pack. " in Windows 10 Virtual Disk Manager after moving a HDD out of another machine and inserting it into a USB enclosure
B) I downloaded HxD as suggested, did Extras > Open Disk > untick 'Open as read only' > Selected the right physical disk
C) Took a while to realize where location 1C2 is... :) You have to go about 29 rows down and then 3 cells to the right. Click on the "42" there and you should see (bottom left) the location (named "Offset") as 1C2. Changed that 42 to 07 and CTRL+S (i.e. saved)
D) Turned external USB power off, back on
E) Now disk showed with drive letter in Virtual Disk Manager but... as RAW, and when going to the assigned drive letter Windows asked if I wanted to format it (WARNING: Click cancel/close the box offcourse here :)). Clicked cancel and downloaded Testdisk 7.1 as another user suggested (a free open source program)
F) Basically did a scan and got it to write out the partition it found. It said I had to reboot. I figured I could just turn off/on the USB enclosure.
G) Turned off/on the USB enclosure.
H) Disk is available, drive letter assigned, data is visible.

WOOOHOOO - Thank you guys!
Thanks be to God also!
Registered to voice my thanks for your extended fix as it is what I needed. Unlike you my disk didn't seem to show as RAW in step E, it just looked the same it did before I did step C. However after step C and D, the drive now shows up in explorer with a drive letter but also an error popped up immediately saying something brief that I can't remember now.

I wish I had taken note of the steps I took in Testdisk as I had to pause and think about them at a couple of points. All I can say is it was really straight forward and quick. You basically search the drive for partitions, it lists them all, then I think it tries to automatically detect which partition you want but asks you to confirm, then it asks you to write the change to the disk and then restart. In my case I only had one major partition. It may be more complicated for anyone who has multiple partitions across a disk and wants to recover them all, maybe not.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.