Error Message when trying to telnet into a Windows 7 machine

Discussion in 'Windows 7 Help and Support' started by Runner14, Jul 1, 2013.

  1. Runner14

    Runner14 New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    Hi,

    I have a 32-bit machine running Windows 7 Professional. I installed telnet server on the Windows 7 machine. I then enabled telnet and started the service.

    I tried to telnet into this Windows 7 machine from a 64-bit machine running Ubuntu on it. I get the following error message each time I try to telnet into it:

    "Failure in initializing the telnet session. Shell process may not have been launched.
    Telnet Server has closed the connection
    Connection closed by foreign host. ”


    I did a Google search on this error message and found many postings noting that this indicated a bug on 64-bit Windows XP (including MS Suppot Article ID: 309523). However, the machine, I have telnet server installed on is a Windows 7 32-bit machine.

    My questions are:

    1) Does this error message indicate there is a bug in Windows 7 32-bit

    2) If not, what does this error message indicate and how can I resolve it so I can telnet into the Windows 7 32-bit machine with telnet server on it?


    Thanks.
     
  2. Runner14

    Runner14 New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    I tried following the instructions from the following Windows KB article: Failure in initializing the telnet session. Shell process may not have been launched. Telnet... (which again is actually for 64-bit Windows XP and not 32-bit Windows 7).

    When I attempted to run "tlntsvr /service" from the command-prompt, I got the following error message: The application was unable to start correctly”.

    Next, when I tried to start the telnet service again, I got the following error message: The telnet service on Local Computer Started and then stopped. Some services stop automatically if they are not in use by other services or programs”.

    I then tried to open up a command-prompt and also got the following error message: The application was unable to start correctly”.

    So, those instructions did not help and actually seemed to have made things worse. I am going to re-image this machine now.

    Unfortunately, I still don't know why I get the
    "Failure in initializing the telnet session. Shell process may not have been launched.
    Telnet Server has closed the connection
    Connection closed by foreign host. ” error message when I attempt to telnet into the Windows machine.


    1) Does anyone know why I am getting this error message?

    2) Does anyone know how I can resolve it so I can telnet into the machine with Windows 7 Professional on it.?

    My apologies for double-posting but I wanted to give an update.

    Thanks.
     
    #2 Runner14, Jul 1, 2013
    Last edited: Jul 1, 2013
  3. Runner14

    Runner14 New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
  4. 4colourAdmin

    4colourAdmin New Member

    Joined:
    Sep 20, 2014
    Messages:
    1
    Likes Received:
    0
    Runner14,
    I am not surprised at the lack of reply as probably not many Admins are using Telnet. I had the same experiences as you have outlined above. I was able to work through them after a bit of searching and trial and a few errors. Try these suggestions:

    Make sure you are not remotely logging in as the Admin user. Try another user account but make sure that User is in the TelnetClients group (add them by running "mmc lusrmgr.msc" from the Start, [Search Programs...] box.

    As to the failure to restart the telnet service it could be that you had not launched "Command_Prompt" as "Run as administrator". Do so by right-clicking on that Command_Prompt menu from the Start menu. It might make a difference, but my application failed to restart just the same. A reboot was required to get all of the components to properly restart in the right order. Once I had gone through these steps I was able to telnet from my Macintosh (10.5.8) to my Windows 7 machine.
    Good luck to those who follow behind us here. dp
     

Share This Page

Loading...