Windows 10 Ethernet and Wireless keep disconnecting - Windows 10 Pro 21H1

Cache

Extraordinary Member
Joined
Oct 6, 2009
Messages
9
CA
Cache1978
Created on September 28, 2021

Ethernet and Wireless keep disconnecting​

Hi,

I have a problem where my ethernet intermittently keeps dropping. Occasionally it happens on WiFi as well and I've also seen it happen on a USB-to-Ethernet adapter.

I have a large network with many other devices connected physically and wirelessly but no other device is affected. For this reason I believe it is an issue with my Laptop. Furthermore, I believe it might be an OS or driver issue rather than a hardware fault because it's not limited to the Ethernet adapter.

The issue is that the Ethernet connection will occasionally drop saying it's connected but with "No internet", however there is also no local network access. When I switch to WiFi most times it will work but sometimes the same issue occurs either immediately or after a little bit of use. A reboot is the only way I can get it to work again and then it only works for a maximum of an hour before it happens again (most often within 30 minutes).

Sometimes it picks up a weird IP address indicating the DHCP server isn't work but it's working fine, other times all the settings are fine correct but still won't work. I tried specifying a static IP and DNS when it occurs but it just locks up when trying.

Things I have tried:
Turned off windows firewall - Not resolved it
Turned off Windows defender - Not resolved it
Ensured will windows updates and drivers are up to date - Not resolved it
Formatted Windows and completely re-installed - Not resolved it
Tried a different network switch - Not resolved it
Tried a different network directly connected to a different router (different network entirely) - Not resolved it
Tried different ethernet cable - Not resolved it
Turned off fast shutdown - Not resolved it
Turned off "Windows can shut this down to save energy" on the network adapters - Not resolved it
Complete network reset - Not resolved it
Virus scan and malware scan - Not resolved it
Tried static IP - Not resolved it
Disabling network adapter and re-enabling but it won't re-enable - Not resolved it
Removed all intel drivers and killer software and let windows chose the drivers it believes is best - Not resolved it

A few things I found in the logs which might be related but i'm not sure:
Microsoft-Windows-Host-Network-Service-Admin

'IpICSHlpStopSharing' : '0x80070032'.

A provider, IntelMEProv, has been registered in the Windows Management Instrumentation namespace root\Intel_ME to use the LocalSystem account. This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

I'm completely out of ideas and have been working on this for 2 weeks now. Any help would be massively appreciated.

Thanks.
 


It sounds like you've already done quite a bit in troubleshooting your network connectivity issues. Here are a few additional steps you could consider trying:

1. Update Network Adapters:
- Go to Device Manager, find your network adapters, right-click, and select "Update driver".
- Check the manufacturer's website for the latest drivers and install them directly.

2. Power Management:
- In Device Manager, right-click on your network adapter, go to Properties, Power Management tab, and uncheck "Allow the computer to turn off this device to save power".
- Disable any power-saving options in the BIOS related to network adapters.

3. IP Release/Renew:
- Open a Command Prompt window with administrator privileges and run:
Code:
     ipconfig /release
     ipconfig /renew

4. Network Reset:
- Use the built-in network reset feature in Windows to clear network settings and reinstall network adapters.

5. Check Router Configuration:
- Ensure DHCP settings on your router are configured correctly.
- Check if there's a lease time set on the DHCP server.

6. Event Viewer:
- Check Windows Event Viewer for any recurring error messages related to the network adapters or connectivity issues.

7. Review Network Protocols:
- In network adapter settings, verify that only protocols you need are enabled (e.g., IPv4/IPv6).

8. Contact Manufacturer Support:
- Reach out to your laptop manufacturer for specific guidance related to known issues or firmware updates.

It's advisable to isolate the issue further by testing your laptop on a different network, ruling out any possible router-related issues. If the problem persists across different networks, it could point to a hardware fault with the network interface.
 


Back
Top