Files not showing on external drive

#1
Hi,

I've got a Seagate 2TB external drive for backup. When I backup files and click on the drive it just says 'this folder is empty'. However, if i search for a file or directory it appears. I did read something to the effect that Windows 7 fails to show the files if a drive is very large but I can't find the source of that now. I've searched high and low online and would have thought if it was a common problem there would be many instances.

To try and get round this I partitioned the drive into partitions which were the same as the drives I wished to back up and which themselves display their contents okay in explorer. Even with partitions the contents are still not showing unless I search for a particular item.

Really can't understand this as the files are there and explorer can see them if I go via search but that's not a viable solution because most times you will want to navigate yourself.

Would really appreciate any thoughts.

Many Thanks

Peel
 


Joe S

Excellent Member
#2
Are you using software for backup? Is the drive space used? Try selecting Show Hidden Files and see if that helps.
Joe
 


#3
Hi Joe,

Appreciate the reply. I'm using Handy Backup which I've used many times no problem. Tried 'Show Hidden Files' to no avail. The strange thing is, when the backup begins I can view the files for a while but later they disappear but they are there because as I say I can search and find them. I haven't been able to establish at what point they disappear.
 


#4
I've never heard of that on before. I would use one the well known back up software utilities like Acronis, Macrium and Aomei. The firs it a trial and the pay for but the other two are free. I've used all 3 and prefer to use Aomei.
 


#5
The trick that worked was to Show Hidden Files but also to uncheck the "Hide protected operating system files" checkbox. Neither one on their own works, both changes have to be made. I want to see if there's a way to not have to do that but for a short term fix it does the trick.
 


Joe S

Excellent Member
#6
Smartware that comes on WD externals can cause the hidden file thing is where I found about it.
Joe
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top