Games not working on Windows 11


New Member
Hello, I recently bought a 2022 HP Pavilion running Windows 11. I am a big fan of the Nancy Drew PC games by HER Interactive, I've been playing them for 20+ years. However, the newer games won't work on my new computer. Every time I start the game, it flashes. I've tried changing the refresh rate, running in different compatibility modes, changed the DPI settings.....absolutely nothing is working. I used to play them all on a 2012 HP Pavilion that just died. Please help?

There is a thread about this on the Microsoft Answers forum that might help you. I suggest trying the one described here:

I was having the same issue when trying to load The Haunting of Castle Malloy onto my new Windows 11 computer. I spent hours trying all the recommendations here to date, but was still getting flickers that made the game unplayable.

I did find another recommendation that seemed to work. Basically, as I understand it (which might be an oversimplification, but that's me), the games need some older graphics files and can't find them. And you can't install an older versions onto your new computer without messing things up.

A user on Reddit said he was able to get his wife's to work by downloading the latest version of dgVoodoo2, which identifies itself as "a set of implementation of old graphics API's for Windows 7 and later versions." Once downloaded, he said NOT to install it on your system (hence, messing up your new computer), but rather move the downloaded files directly into your game's file. From there, locate and copy the files with the dll extension back into the game file.

Downloads - Dege's stuffs

When I did this, the game opened in a small window, but I was able to use the settings in the game, "full window 2", to get a good sized playing area. It now says dgvoodoo2 in the lower right corner, so I guess it's working!

Came back to share it here because it appears a lot of us are having this problem. Maybe someone from Windows could create a patch using that info?

Good luck and happy sleuthing!

And possibly the one described.... here:

Replied on October 12, 2022Report abuse
Hello Frustrated Gamer!

I, too, was INCREDIBLY frustrated by this particular problem on the Deadly Device and Ghost of Thornton Hall. The trick that helped fix this required a deep dive into reminding myself how computers work now, versus before this. We're all prone to looking at software issues rather than hardware defaults. Thankfully, I'm a Nancy Drew-raised girl and I'm not one to give up because a door is locked.

Long story short, new laptops usually have two graphics processing units, and if your game is trying to run off the wrong one, it loses its mind. I did try Lenka's solutions, to no avail, but this workaround eliminated the need to run in compatibility mode and lets me leave my display resolution in that delightful 2560x1440 ratio.

If you open your device manager, you'll be able to see what you've got under the hood. Search it in your apps and open the display adapters:

I personally have a NVIDIA GeForce RTX 3070 Ti GPU and an Intel Iris Xe Graphics card (which is the default if I go into System -> Display -> Advanced Display), if that's relevant to helping anyone else troubleshoot. My refresh rate is still set to the lowest setting of 60 Hz.

From there you can open your GPU's control panel. Mine is NVIDIA, so I searched NVIDIA Control Panel, and tricky tricky, my apparently 2D display settings are hidden in "Manage 3D settings". Ignore global settings and click on the Program Settings tab.

Select the Nancy program giving you trouble. If it's not open, you can navigate to it in its directory using the "Add" button. Then make sure your graphics processor is that sweet additional card, and not the integrated one.



Hit Apply, and with luck, Happy Sleuthing!


Edit: Assuming external links are allowed, further explanation:

9 people found this reply helpful
Was this reply helpful?
Yes No

There is a thread about this on the Microsoft Answers forum that might help you. I suggest trying the one described here:

And possibly the one described.... here:

Thank you for your reply! Unfortunately I had seen both of these before and neither of them worked. I'm not 100% sure I did the dgVoodoo2 one correctly though, it was a little confusing.