Help: I can't delete my own folders!

Discussion in 'Windows 7 Help and Support' started by tomservo, Dec 29, 2009.

  1. tomservo

    tomservo Senior Member

    Joined:
    Dec 29, 2009
    Messages:
    18
    Likes Received:
    0
    I upgraded today from Windows XP to Windows 7. I have a drive that was created in Windows XP that I'm trying to delete folders from. I get the message: "You need to provide administrator permission to delete this folder." So I click Continue. It then says, "You need permission to perform this action." and "You require permission from Desktop\Dave to make changes to this folder."

    There's just one problem... I AM DESKTOP\DAVE! I changed the folder so that the owner is my account (dave). Then it tells me I need dave's (i.e. my own account) permission to delete! I did the "take ownership" thing with this and other folders, but sometimes Windows just ignores my changes and pretends I never made them, and sometimes it gives me the message I get above.

    Why is windows 7 acting all pissy like this?? :mad::mad::mad:
     
  2. pbcopter

    pbcopter Honorable Member

    Joined:
    Jan 15, 2009
    Messages:
    226
    Likes Received:
    12
    Taking ownership doesn't automatically change the permissions. Make sure that the permissions are set to allow you full control.
     
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I gavve this peoble also, only appears on the destop ss far as I know.You have to delete all the files and empty foldes in the directory you want to delete and theat wikk work,
     
  4. sallen

    sallen New Member

    Joined:
    May 6, 2010
    Messages:
    4
    Likes Received:
    0
    try this to control folders

    Go to control panel. Then Action Center. Change user account control settings. Slide the slider to never notify. Click ok and restart the computer. DONE.
     

Share This Page

Loading...