[Help]Win 7, no network after Standby/Hibernate

Discussion in 'Windows 7 Networking' started by ichessblumen, Aug 4, 2010.

  1. ichessblumen

    ichessblumen New Member

    Joined:
    Aug 4, 2010
    Messages:
    6
    Likes Received:
    0
    Hello all,

    I ran out of options to solve the following problem and I need your advice.

    After return from standby or hibernating the network and internet connection did not re-establish.
    The eventviewer ( I typed "eventvwr.exe" in the "Run" window) shows that the DHCP server( which's my router) does not provide an IP address for that computer. Other PC's ( 4 ) in the network are working well and showing not that behaviour and 2 of them are also on Win7.

    I tried:
    - static IP adress -> no success
    - checked the router and the belonging address range -> no success
    - disabling network adapter ( Network IC) in hardware manager when returning from standby -> works
    - then re-enabling network adapter in hardware manager when returning from standby -> failure, Win7 freezes, hard boot
    - same behaviour when I try with MPstandby handler and external batch file.
    - in command console I tried different "powercfg" commands
    - latest driver for network adapter
    - unchecked in properties tab" this device can wake up...." -> no success

    Network adapter can be disabled and enabled in hardware manager once a network connection is established but not when returning from Standby/Hibernate neither manually in hw manager nor with batch files using devcon.exe

    Another strange behaviour: from normal boot the name of the network connection is "Lan-Verbindung" ( in English OS it is just "network") . But after return from sleep/standby the name changes into "Lan-Verbindung 2" ( or in English OS it would be "network 2")

    Any other ideas ? I've searched and searched....

    Thanks.
    ieb
     
  2. ichessblumen

    ichessblumen New Member

    Joined:
    Aug 4, 2010
    Messages:
    6
    Likes Received:
    0
    *push*

    any hints?

    meanwhile I've tried latest driver (rtl1867) but with no success. even deleting the drivers in hw manager an using the native one from win7 didn't work.

    any help is highly welcome.
    ieb
     
  3. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Have you tried: device manager -> your network adapter/NIC -> Right click -> Properties -> Power management tab -> Uncheck “Allow the computer to turn off this device to save power" -> Ok, and restart your pc for the changes to take effect.
     
  4. ichessblumen

    ichessblumen New Member

    Joined:
    Aug 4, 2010
    Messages:
    6
    Likes Received:
    0
    hello cybercore,

    thanks for your advice. As I wrote "unchecked in properties tab" this device can wake up...." -> no success". I did that with no success. That was the first thing I thought of.

    I tried alot and the only thing left is buying a discrete network card instead of using the onboard nic.

    best regards.
    ieb
     

Share This Page

Loading...