I am running 2 PC's with Windows 7 Ultimate 64bit. In explorer both list each other but cannot access shared folders. In Homegroup both say ther is no homegroup on the network . Both have the newtork set to Home. I also have a Vista Ultimate 64 bit PC which can see both Windows 7 PC's and they can both see the Vista PC

I have turned the firewalls off
I have tried leaving one home group so that I can join the other
No difference - has anyone come across a similar problem and solved it.


Senior Member
Do both computers have the same username and password on each.

For instance:

PC1 has a user called homeuser with password "password"
PC2 has a user called homeuser with password "password"

I thought you needed to have something like this setup in earlier versions of Windows...like XP. Not sure about 7 - we use Domains here at work.

Yes both PC's have user with same username and password.

My advise is to ditch the 'homegroup' bullcrap in Windows 7. Set the network type to Work instead of Home.
Just add each computer to a normal windows Workgroup by doing this

1) Right click on Computer (aka My Computer)
2) Select Properties
3) left click on Change settings in the Computer Name, domain and workgroup section
4) left click on Change in System Properties tab
5) Select Workgroup, add each machine to the SAME WORKGROUP. I would call it MSHOME or something easy to remember
6) Supposedly you have to reboot each machine after making this change, I recommend it but sometimes you will be able to view the work group without doing so..

Here comes the most important part

7) Now, find a directory you want to share on one of your Windows 7 machines, right click on the folder and choose Share With and choose Specific People
8) Type the name Everyone in the box and click on Add. This will allow anyone on the network to at least view the folder.. If you want everyone to be able to edit, delete, create files you just need to change the permissions to do so.

Hope that helps!

Last edited:
My advise is to ditch the 'homegroup' bullcrap in Windows 7. Set the network type to Work instead of Home.
Just add each computer to a normal windows Workgroup by doing this
Hope that helps!
That's fine for Ultimate, but won't work for Home or Premium editions, The best option is to NOT use the SEP firewall and use the Windows 7 firewall.

I will be digging further into this and will develop a solution in the future.

The same issue is happening to me. I have researched this for the last three days and haven't found an answer that has fixed my problem. I am still unable to see PC2's Homegroup and PC2 cannot join my home group citing it is "incorrect password." I also see that PC2 was having trouble installing MW2 via steam games, stating a "network error (16)"... Whenever I downloaded and attempted to use Network Magic Pro, it believed that PC2 was on "ICS" and Network Pro did not support it and must disable. Though during installation for PC1 for network magic pro, I didn't get an "ICS" message. Interesting.

The reason why the homegroup thing is so important is for 1) File sharing and 2) I believe it ties closely into why she cannot connect to games on MW2 PC Multiplayer. She is stuck at "synchronizing settings..." for a long time. There seems to be other things going on that I'm not very sure about.

I have double and triple checked that all computers are on the same network, network discovery is on, have the same time synchronization, and all services are started (and automatic in most cases). Yet this issue still seemingly persists. PC2 has a fresh install of Windows 7. The router configurations (Ultraline Series 3) look to all be correct. The firewall configurations have not been messed with and no third party ones have ever been installed. As a side note, I do work for a System's Support group for a major tax software development company and I am wholesomely stumped by this.

My next steps are
1) turn off both firewalls (though I have tried this before but will again)
2) Possibly format PC1 to ensure there are FRESH installations on both PC's
3) Exchange the router for a new model / etc.
4) Throw in a new network card for PC2307

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.