Windows 11 How to stop file expolorer from opening on boot


New Member
Jan 7, 2023
I have an iSCSI drive mounted on D: for steam library from my TrueNAS server. Every time I reboot my computer this drive pops up in file explorer. How can I disable this? I have checked the following settings: Apps/startup - nothing here about file explorer. Task manager/startup apps - nothing here either. cmd/shell:startup - is empty. File explorer options has "restore previous folder options at logon" unchecked. I can find no setting in the iSCSI initiator in this direction either. Help?
I would grab a copy of autoruns and look through there. Honestly anything could attempt to open explorer or a file. Could even be a scheduled task.

@Neemobeer Thank you for that suggestion. I did as you said but I can't see anything obvious in autoruns either. Checked the "logon" tab and the "scheduled tasks" tab. Tried searching for "iscsi", "D:", "steam" etc. But nothing obvious. Any suggestion what to look for?
Truthfully it could be anything. You can click the save button and export the results. You may want to do a replace on the output and replace your username with something like <redacted> before posting output.
Top Bottom