I get error 0x80072f8f on my tablet while trying to connect to store

#1
Like i said in my title i'm getting an error every time i try to open up my store. I keep on searching it up online but i haven't found anything to help me it says We weren't able to connect to the Store. This might have happened because of a server problem or the network connection may have timed out. Please wait a few minutes and try again.
Please help.
 


Yogi

New Member
#2
Did you ever get this resolved? I have the same issue. I connect to my WiFi. I can browse the internet, but it just won't connect to the store no matter how many times I reboot the thing. I've also tried it over different WiFi connections and still get the exact same error message. I'm hesitant to Factory Reset the thing cuz I'll lose all my gamr progress.
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#3
Error 0x80072f8f is a setting error with lots of possible issues but the main two are;
  • system time/ date is more than an hour out... just reset it
  • I-explorer is corrupt... (again reset and restart system)
Screenshot (189).png
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.