Impossible to install Microsoft Visual C++ 2015-2022 Redistributable (x64)


New Member
Windows makes it is impossible for me to install the Microsoft Visual C++ Redistributable x64 package.
(my system is Windows 10 x64)

A simple search reveals that many Windows users have this issua and it's become a notorious problem.

What I've done so far:

In Control Panel I uninstalled all instances of Microsoft Visual C++ ... Redistributable, all existing versions.
I downloaded MS Troubleshooter and made sure there are no leftovers of the uninstalled packages.
Fix problems that block programs from being installed or removed - Microsoft Support

I searched registry for "Microsoft Visual C++" and deleted all instances that contained "Microsoft Visual C++ ... Redistributable x64 or x86"

Deleted all content in \Downloads and \ProgramData\Package Cache

In Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products
I deleted all sub-keys referring to Visual C++

and then restarted PC.
I made sure that in services.msc Windows Installer is running.

After doing all this, VC_redist.x86.exe and it installs properly; however x64 fails to install, and it will forever output the same error:

First issue: when VC_redist.x64.exe runs, it stops and says "The feature you are trying to use is on a network resource that is unavailable" and prompts to choose the source in the "Use source" field.
I click Browse and surprise, the vc_runtimeMinimum_x64.msi file is actually there (created by the same VC_redist.x64.exe in this folder: C:\ProgramData\Package Cache\{D5D19E2F-7189-42FE-8103-92CD1FA457C2}v14.36.32532\packages\vcRuntimeMinimum_amd64);
and if I click OK it spits another error- "not a valid installation package" !
I attach both error screenshots.
Why stupid Windows says it's unavailable is a mystery...

I would appreciate any help.
I understand that you are experiencing difficulty installing the Microsoft Visual C++ Redistributable x64 package on your Windows 10 x64 system. This is indeed a common issue that many Windows users have faced. I will try to provide some assistance based on the information you have provided.

First, it's important to note that the Visual C++ Redistributable packages are essential components required for running certain applications on your computer. Therefore, it's crucial to have them installed correctly to ensure smooth operation of various software.

From the steps you have already taken, it seems like you have done a thorough job of trying to resolve the issue. However, there are a few additional troubleshooting steps that you can try:

1. Download the Visual C++ Redistributable packages directly from the Microsoft website: Sometimes, the packages obtained from third-party sources or installer files may be corrupted or incomplete. By getting the packages directly from Microsoft, you can ensure their integrity.

2. Run the installation as an administrator: Right-click on the installation file (VC_redist.x64.exe) and select "Run as administrator." This might help in providing the necessary permissions for the installation process.

3. Temporarily disable any antivirus or security software: Sometimes, security software can interfere with the installation process. Temporarily disabling them before attempting to install may help.

4. Use the Windows Update Troubleshooter: The Windows Update Troubleshooter is a tool provided by Microsoft to automatically detect and resolve issues related to Windows updates. Running this tool might help in identifying and fixing any underlying problems.

5. Perform a clean boot: A clean boot starts your computer with a minimal set of startup programs and services. This can help identify any conflicting software or processes that might be causing the installation issue. Instructions on how to perform a clean boot can be found on the Microsoft website.

6. Check Windows system files for corruption: Corrupted system files can sometimes prevent the installation of software. You can use the System File Checker (SFC) tool to scan for and repair any corrupted files.

To use the SFC tool, follow these steps:
- Open the Command Prompt as an administrator.
- Type the command "sfc /scannow" (without quotes) and press Enter.
- Wait for the scan to complete and follow any instructions provided.

If none of the above steps resolve the issue, you may need to consider more advanced troubleshooting options such as resetting the Windows Update components or performing a repair installation of Windows.

Remember to create a system restore point or backup your important data before attempting any major system changes.

If the problem persists, I recommend reaching out to Microsoft Support for further assistance, as they have specialized knowledge and tools to diagnose and resolve Windows installation issues.

I hope this information helps you in resolving the problem with installing the Microsoft Visual C++ Redistributable x64 package. Good luck!
Thank you, actually I've done all that, but I the issue is not solved, same errors come up every time.
Which version of VC++ RC are you trying to install? Nevermind, see it in the title. Can say I've ever had an issue with them. Any endpoint protection or excessive firewall rules in place?

Running the installer locally or or from some network storage?
Is this just a home computer or work environment?
Just a home PC, no particular firewall setup, no external storage.
Running the installer from the sdd C:\ drive

I attach the screenshots with the error messages.


  • VC_scr.png
    17.6 KB · Views: 11
I'll be honest you may have done some damage deleting registry values.
There should be a log in %TEMP% with more details or try
<installer.exe> /repair or /uninstall first
With the package cache nuked you may need to do <installer.exe> /layout then locate and run the msi from the directory it creates