Installed More Ram And..


New Member
Jan 15, 2009
I upgraded from 2 gig to 4 gig today on my laptop and I have a question.

When I go into my BIOS it states

Memory installed 4096
Memory Available 3327

Where is the other 769? That's a lot of memory to be not accounted for.

In windows 7, I have the 64 bit version, it acknowledges that i have 4 gigs.

My computer says its capable or 4 gigs max. I searched a bit online and it seems normal but got no real answer's.

sounds like bad RAM. Do you have another computer to which to test it out with?
No I don't have another computer to test it with.
I don't think it is bad ram because the system does recognize that I have 4096 installed. Possibility though.

I suppose it could be allocated to video.
My two thoughts on this are

My video card is one that claims 256 but really only has 64 built in and borrows the rest from the system ram. But the difference is only 192.

I thought the video card using system ram was software controlled. I'm getting this data from the BIOS before any video drivers are loading.
It's video memory offset allocation.
It's also hardware controlled, with software control in an OS.
So yeah, no worries, it's all being used.
hey i am sort of having the same deal. I have 7 (64-bit version) installed on my computer with 4 gigs of ram. The bios says there's 4 gigs of ram and if you go to system underneath control panel it says 4 gigs of ram. But my gadget and underneath system information its says 4 gigs of installed and 3.2 gigs of physical...any clue??
Last edited:
Sometimes it's "Integrated Video RAM" -- for example your computer might have 384KB Integrated Video RAM - possibly a bit high for a Laptop --usually 128 KB RAM. This will still be part of the 4GB address space which won't be available for "OS adressing". Same with the BIOS itself.
Other pieces of hardware will also use parts of the 4GB RAM address space. For example say an external USB TV Tuner etc etc. These will also "Eat up" part of the 4GB address space.

Last edited:
as some of the previous speaker said. Due to memory allocation to your gfx, the os itself doesnt use the full
size of the RAM. I think there should be a setting in your BIOS where you can disable /sideport memory/ and I think this is the solution for you.
Top Bottom