No audio devices are installed (Fujitsu) and...

#1
Hello,

I searched before asking but none of these solutions helped me.

Three days ago my Fujitsu Siemens Pi 1536 suddenly crashed - the screen went crazy and I pushed my laptop's power button off. Then I turned it on and everything went okay - then I realized I have no audio drivers anymore. No sound, nothing.

http://i33.tinypic.com/11742eb.jpg - 'No audio devices are installed.'

http://i38.tinypic.com/23hlqw5.jpg - Windows can't detect a problem or automatically update.

I tried to reinstall them (Realtek) but this didn't help me. Tried every possible way to make things work. Uninstalled them; reinstalled them; installed them over the old ones; disabled and enabled... Still nothing.

Of course, after that I decided to reinstall my Windows 7 (clean install). I never had problems with installations until now. I boot from DVD and it loads the files, but then black screen comes with a cursor and restarts after 3 seconds. So it's kinda a restart loop. Burned Win 7 on five different DVDs - none of them work! It's the black screen with cursor over and over again.

Anyways, I finally succeeded to reinstall my laptop (clean install) and now I'm using Windows XP. After that I also installed all of my drivers and the only problem continues to be the audio.

http://i36.tinypic.com/8w04f8.jpg - In Device Manager there's no Realtek option.

So I still can use my laptop but there is no sound. I'm stuck and I'm going mad now. What the ... happened with my Fujitsu??? Is it a virus? Is my sound gone forever?

Anybody has a solution? I'd be sooo thankful!

Just tell me if you need more info about my laptop:

I have Fujitsu Siemens Pi 1536
Processor Intel (R) CPU T2300 @ 1.66 GHz 167 GHz
RAM 2.00 GB
32-bit Operating System
 


#2
Hello George, welcome to the forum. : )

If your Realtek is not listed in device manager (under 'Audio codecs'), then something is wrong with this device - perhaps broken? Are there any external audio cards connected to your laptop that might be conflicting? Have you upgraded bios lately?
 


#3
Hi cybercore :)

Thanks for the quick reply! No, nothing external is connected. I read on some places that I should try updating my BIOS because there could be some conflicts etc. but I'm scared doing it by myself (I never did this).

I guess my last solution would be updating the BIOS.
 


Last edited:
#4
Please help me. Can anyone tell me how exactly do I flash my BIOS...

Thanks!
 


#5
Please help me. Can anyone tell me how exactly do I flash my BIOS...

Thanks!
Hi,
I have also a Pi1536. Your problem probably comes from the broken sound card. You can try an bios upgrade (official).

When I wanted to upgrade my laptop to CPU T7200, 4gb ram and change de VGA card to an Ati HD 4570, I used an Alienware Bios (version 1.19) and it works.

Windows 7 regconizes only 3.25Gb because of chipset limit. But it's fine.

More details at : amilo pi 1536/1556 alienware bios for memory upgrade and video card - LaptopVideo2Go Forums

Regards.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.