Windows 10 NTFS Access Problems

Cainy

New Member
Good Evening Windows Forum,

I have a very bad problem with a (or better two) windows installation(s) and it's NTFS permissions..

First I am gonna provide you with all the info and problems I face:

The story:
My dad's pc was very slow on windows 7 on an HDD and so I thought I'd install him a fresh and clean win10 installation on a brand new 512GB SSD..
I unplugged the old HDD and installed win10 on the SSD by using a Bootstick created with MediaCreationTool.
Up to this point, everything looked very good and windows 10 booted perfectly and it does so every time.
Now I booted again and replugged the old HDD because he wanted to access the data on the old drive while using his new installation.

And here comes the big problem..:
He had no access on his C Drive (SSD, Win10) and also no access on his D Drive (HDD, Win7) up to the point where he has problems starting programs, writing data in specific directories and altering specific files.
I cannot say whether or not there is any distinct pattern in the data he cant access but there are multiple.

Things I checked myself:
1. If you boot from the HDD (win7) you have the same issues.
2. The account on win10 is an administrator
3. If you unplug the HDD and boot Windows 10, you have the same issues.

4. I tried altering the owner of the whole C: and D: Drive to PCNAME/Administrator and have the same issues.
--- When I try this, I get a error message for all the files I cant alter the permission on:

iu


(This is not a screenshot of the PC i talk about, because you probably wouldnt understand the language but it has the exact meaning)

So yes, I tried this "workaround" of changing the owner from TrustedInstaller to PCNAME/Administrator of the drive and the problem persists.

At this point, I have no clue what to do next and I am pleased to hear your opinions.

Thanks, John
 

Neemobeer

Windows Forum Team
Staff member
All accounts, administrators included, run as standard accounts unless the UAC is invoked at which point that given process will receive an elevated rights token running as an administrator.

Windows uses DACL permissions which can mean even an admin may not have access but it's up to their discretion (the D in DACL) to grant access. In some cases this is required.

If the drive in question is mounted on say D:

You can run the following two commands from an elevated command prompt (right click "run as administrator")
takeown /F D:\* /A /R (this will take ownership of everything on the extra drive) this is necessary to grant access
icacls D:\* /E /T /grant:f administrators (this will grant adminstrators full access on everything in the D drive.
icacls D:\* /E /T /grant:f users (same thing but for regular users as well.
 
Top