Numeric keypad not working

Discussion in 'Windows 7 Help and Support' started by splashchris, Mar 26, 2009.

  1. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    Hi all. I've got a strange one here. So far it's stumped me and all the techs at CompUSa. MY numeric keypad does not work in any Microsoft Office program, nor does it work in Firefox or Google Chrome. Here's the tricky part...it works fine if I open the calculator, a notepad document, or use Internet Explorer. It also works fine in the bios setup, i.e. setting the time, etc.

    Yes, NUM LOCK is on and no keys are stuck. Yes I tried three different keyboards, both PS2 and USB, as well as a brand new motherboard. I'm still having the same problem.

    Keys affected: arrow keys, page up, page down, 0123456789, - +and .

    Forward slash / and astrisk * still work.

    Again, all keys function normally in calculator, notepad and Internet Explorer. I'm totally lost. I hate having to use the number keys above the qwerty keyboard. Very cumbersome.

    Any suggestions would be greatly appreciated.

    Chris
     
  2. Thomas

    Thomas New Member

    Joined:
    Dec 1, 2008
    Messages:
    142
    Likes Received:
    7
    Keyboard

    I had the same problem. :confused: I have a Logitech Laser . I had to goto Logitech websight and download the driver for it. It has worked just fine ever since . :p

    Thomas :cool:
     
  3. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    By Logitech laser, I'm assuming you mean a mouse. I also have a logitech laser mouse, and coincidentally, the problenms startd around the time I got the mouse. I'll check out Logitech's website and see about a newer driver
     
  4. Cartman

    Cartman New Member

    Joined:
    Mar 26, 2009
    Messages:
    30
    Likes Received:
    0
    By Logitech Laser I assume he ment cordless logitech keyboard and mouse. So try to search for newest drivers for your keyboard.
     
  5. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    Still have the same problem. My keyboard is a Microsoft USB. I have tried other keyboards, etc. as well as a different mouse. I have the latest mouse driver installed. Not sure where to go on this one, I've never seen anything like this before.
     
  6. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    Maybe a stupid question, but have you tried Windows Update? It might locate the driver for you.
     
  7. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    Trust me, no question is stupid :)

    Yes, I did try Windows update. The only thing there is an update for my NIC card, I'm sure we'll get this sorted out. Thank you for a great suggestion. I'm not sure this is a Windows issue though. Everything was working a few days ago and darned if I know what went wrong along the way. I thought for sure the new MOBO would have fixed it. Also, I never realized just how often I use those keys until I press them and nothing happens :confused:
     
  8. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    Here is an idea...
    Try uninstalling any keyboard/mouse software in "Programs and Features". Next check Device Manager and uninstall the keyboard/mouse devices there too. Reboot and see what happens. The "Found Hardware Wizard" should reinstall the keyboard and mouse, hopefully fixing your problem.
     
  9. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    I'll give that a try and post back
     
  10. Thomas

    Thomas New Member

    Joined:
    Dec 1, 2008
    Messages:
    142
    Likes Received:
    7
    Logitesh MX-5000

    Do not use Windows 7 update, do it yourself. Go to your keyboard web sight amd download the driver software and install it yourself. Once you have done this it will work all ok. :D

    Thomas:cool:
     
  11. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    I went on the Microsift website and there is no driver available for my keyboard (KU-0459). It's a straight Plug n play keyboard
     
  12. splashchris

    splashchris New Member

    Joined:
    Mar 26, 2009
    Messages:
    26
    Likes Received:
    0
    [RESOLVED] keypad issue

    Hi all. It's taken me a solid 2 weeks to fix this problem. As suggested, this was a software issue. I had to reinstall Windows 7 64 bit version 7057. Once reinstalled everything went back to normal :D
     

Share This Page

Loading...