ODBC32.dll problem

mike21

Honorable Member
I cannot open PDF files in Foxit Reader because of apparently a problem with file ODBC32.dll in the Windows System folder, error 0xc000012f. I tried uninstalling and re-installing the program but the same result. I tried installing Adobe Acrobat Reader but it will not install. I thought I could replace the file from one on my laptop - the same latest updated version of Windows 10 but I was stopped and needed TrustedInstaller. Thinking I was getting out of my depth I gave up - the file on the laptop is dated 15.02.2022, the same as the problem one on my desktop, presumably both installed from the same Microsoft update. I ran sfc /scannow and other DISM procedures but it was clear. Word and other programs run OK, although I get an odd message about email clients from time to time. One post suggests downloading a Visual C+++ version 2015 program. Any suggestions please.
 

mike21

Honorable Member
Further information. I tried to open a PDF on my laptop and it opened in Chrome, I then made Foxit the default and tried again but then I could not access any of my files - they displated but when I tried to open any the message was that the location had changed. I did a system restore but still the same new problem - the laptop is now unusable, probably from the same initial cause.
 

mike21

Honorable Member
I have checked the site and have three versions to choose from viz: ARM64, X86, X64. I am running Windows 10 ver 21h2 (the latest) - I think I should choose ver X64 but would like confirmation
 

bochane

Excellent Member
That depends on your Windows, see: All settings > System > Info: System type
 
Last edited:

mike21

Honorable Member
I have tried to install the X64 version but it has failed - see 3 attachments detailing the error messages
 

Attachments

  • Visual C notice 3.JPG
    Visual C notice 3.JPG
    33.5 KB · Views: 64
  • Visual c notice 2.JPG
    Visual c notice 2.JPG
    25.5 KB · Views: 61
  • Visual C notice 1.JPG
    Visual C notice 1.JPG
    37.5 KB · Views: 64

bochane

Excellent Member
So the older version cannot be removed with the message "Contact your technical support group".
Is it a computer from company with a support group?
That worries me, I don't know how to solve it.
Anyboby else?
 

Neemobeer

Cloud Security Engineer
Staff member
Do you use any type of system cleaner utility?

C just means error in that status code
The facility is 0 which is the generic facility when there is nothing specific for the problem
012f is not documented, so could be related to an overzealous cleaning utility or corrupted library.
odbc32.dll is the dynamic library used by the ODBC command utility and is farily important to the operating system.

I would start by running a check of the system files.
  1. Click on the start button
  2. Type cmd
  3. Right click on 'Command Prompt' and select 'Run as Administrator'
  4. In the command prompt type sfc /scannow
  5. Once that command finishes check the output to see if anything was repair
  6. Optionally it may ask to reboot.
  7. Repeat steps if it fines problems and needs to reboot
 

mike21

Honorable Member
The computer is eleven years old, as is the laptop (although both have been upgraded with an SSD and extra Ram) - the company is no longer in business. I ran sfc /scannow and no problems were found, I also tried a refresh, keeping apps and files, but after over four hours the refresh failed and I was back where I started. I think it was a windows update problem as both the desktop had the same dated dll - the date of an update - and the same problem when I tried to use Foxit for PDFs, but sfc /scannow worked on the laptop. I have now set PDFs to open in Chrome and although the problem remains it is acceptable. Presumably the update had not been tested on PCs that old, although this is the first that has gone bad, and on both computers.
 

bochane

Excellent Member
Recap: you have a PC and laptop, the laptop behaves well, the computer is failing, both are from about the same year, both from a company now out of business. You tried a refresh, that is a re-install of Windows keeping your files, but that went wrong. The sfc /scannow detected nothing.
That only leaves a full re-install?
 
Last edited:

mike21

Honorable Member
I know that a full re-install would be the solution and I will have to do it. I have checked and have 56 programs to re-install, although they do not need to be done all at once, and then find drivers for the added video card etc. Would it solve all problems - for instance I have to run chkdsk /r every time before I make a Macrium image - an extra half an hour every time. At 94 it is a daunting task.
 

bochane

Excellent Member
Neither for me, at my 77!
Have you ever thought of starting with a new PC?
Having both on the same network makes it a lot easier.
 
Top