Odd one with Wifi

daveinlv

New Member
I'm trying to figure out what is going on with a Dell Latitude 5480 and an Intel Corporation Wireless 8265 / 8275 (rev 78). The Latitude in question has an SSD with the latest Windows 10 installed and a second SSD with Ubuntu 20.04. The user spends most of his time using the Ubuntu SSD, where he gets expected thruput on any wifi network he connects to. However when he needs Windows, he sees abysmal download and somewhat expected upload. Since this user is semi-clueless with technical problems on his computers. I spent a 20 year career as a sysadmin/"windows janitor" but retired in 2010, so my Windows tech skills have atrophied, but since I'm retired, I've become the defacto neighborhood tech support. If it was up to me, I'd just stay on Linux, but he has some programs he needs to run that do not play well with the Wine windows emulator.

A run with the speedtest website on Windows, on a Starbucks wifi showed less than 1mbps download (this value has been similarly duplicated on other access points) and an upload of 5-6mbps upload, whereas with the Ubuntu SSD installed, 20-30mbps down and similar normal values of upload. I've tried downloading/installing the driver specified by Intel on their website, with no difference, other than Windows deciding the driver on WU was the correct one and reinstalling the WU one. What gives?
 

Neemobeer

Application and Cloud Security Engineer
Staff member
A few items to look at
  • Make sure the wireless driver is the most current
  • Look for any packet shaping or QoS software in place
  • Is there a VPN in use? These can greatly reduce speed
  • Security software
  • Wireless protocol in use such as 802.11b
  • If Hyper-V is installed I've seen the virtual network functionality can degrade network performance
 

daveinlv

New Member
Thanks for the reply..

As for the wifi driver, I assume its the latest, as it came from WU. As I said previously I *tried* to install the suggested driver downloaded from
Intel, but WU kept putting its driver back. I experienced this behavior early on while trying out Windows 10 soon after release. I had a laptop with
Nvidia video, and I kept getting frequent BSODs from the WU Nvidia driver, so I downloaded and installed the recommended one from the Nvidia
website, I'd get it installed and determine that it appeared the BSODs were gone, and WU would remove it and replace its buggy driver..

As for packet shaping/QOS there's none.

OpenVPN is installed, but the abysmal download speed is seen with or without the VPN on.

The only security s/w is the built-in defender.

The access points I've seen this problem are my home wifi and several Starbucks, and I've noted that in all cases, there is a strong wifi signal and
the connections have been 5Ghz 802.11a.

As for HyperV it is installed, as I was trying out HyperV virtualization to see how it stacks up to KVM. The end user does not need it so if you think
this could be the problem, there's no problem in my removing it.
 

Neemobeer

Application and Cloud Security Engineer
Staff member
Remove the hyper-v components. I have personally seen the same issue with Hyper-v 1mbps or less speed.
 
Top