Windows 7 Pin to taskbar problem

Discussion in 'Desktop Customization' started by wt.pm, Jun 18, 2009.

  1. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Last week, the Windows Explorer disappeared, and I could not get it to pin back. I finally found some place that had a check list of items pinned to the taskbar. Explorer was still marked, I unmarked it, closed everything out, (said oh s**t, I'll never find that again), tried successfully to repin the icon. This morning the icon had been replaced with a white broken folder, the one with the two squiggly lines through it, and would not work. I clicked on "unpin", now I can't get it it pin back, and of course can not remember where I found that screen that worked.
    I have been on so much pain medication the last month or so my memory has not been so good.
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hey wt.pm,

    Are you referring to the Libraries link or to a Windows Explorer window that open up the contents of the hard drive?
     
  3. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    Are you able to Right click the Start button, Open Windows Explorer, then right click the window that opens and "Pin this program to Taskbar"?

    That should do it. If not, we got some trouble shooting to do
     
  4. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Mike that is the problem I was trying to describe, I don't guess I did that good of a job. Even though you did understand, kind of.

    reg, it's the one that is actually yellow folders in a blue holder. Personally I think it looks like a deformed lego. Actually it opens up to the libraries folder. But, when you hover over it, all is says is "Windows Explorer". If I remember it is one of the default icons on the taskbar when you first install.
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Unfortunately, I don't use the Libraries function at all.

    But, if you right-click on the Computer icon on your desktop and locate the Libraries entry in the tree, drag it to the desktop and choose Create Shortcut Here.
     
  6. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    I don't use the libraries either, however you can change this to open at any place you want. I have the icon on my desktop, but I want it pinned to the taskbar, like it was originally, but it keeps disappering, then I can't repin it until I unpin it even though it is not there. Here is a screenshot of me trying to pin it to the desktop, so you can see what it is doing.
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Can you pin thje shortcut?
     
  8. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    If you look at the picture I uploaded closely, you will notice on the bottom right corner of the transparent "icon" I am dragging, there is the "red circle with a slash through it", meaning illegal operation.
    This is exactly what happened before, if I right click on the icon, the option to pin to taskbar is there, (same as before). However last time I managed to open the right settings folder, which said the shortcut was still pinned to taskbar, when I unpinned it here, I could actually re-pin it. That worked for about a week then it disappeared again. So I need to (1) find that option menu again, (2) figure out why it keeps doing this.
    On XP I kept a link to the hard drive on the visible part of the quick launch area, because there are a lot of times when I am working, I need to open another explorer window, and being able to just click on a link instead of opening the start menu then clicking on the shortcut is really nice and a time (and movement) saver.


    Edit;
    While typing this I had an idea, and so I tried to pin a shortcut to the hard drive, but what happened is strange, it said "Pin to Explorer", and the icon disappeared. So apparently the link is still there, the icon display is just not working correctly.
     
    #8 wt.pm, Jun 19, 2009
    Last edited: Jun 19, 2009
  9. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Navigate to the C:\windows directory, locate explorer.exe and drag that to the to the taskbar.

    Make sure to close all open windows and programs as it disappeared for me as well.
     
  10. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    wt.pm

    I'm still a little confused about your problem, but I hope this helps.

    First off, I think this is the location you may be looking for. If you can't see it by navigating, be sure to check to "show hidden files and folders" in the Folders view options
    C:\Users\{your user name}\appdata\roaming\microsoft\Internet Explorer\quick launch\User Pinned\TaskBar

    Just some thoughts that may help:

    Win 7 taskbar only allows for 1 Windows Explorer folder to be pinned to the taskbar. If you try to drag another folder onto the taskbar if you already have Explorer pinned, you will receive the red circle (like your image above)

    You can; however, Pin frequent visited folders to the existing explorer folder that is pinned to the taskbar which is called jump lists. You can drag another folder to the windows explorer folder that is already pinned and it will add it as a jump location. In order for this to work you must have the following to options selected in the Start Menu properties:

    Store and disply recently opened programs in the Start menu
    Store and display recently opened items in the Start menu and the taskbar

    If you want the pinned Windows Explorer icon to open up to My Computer instead of the Libraries, open the properties window for the Windows Explorer icon and type the following in the targt:

    %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

    Good luck, let us know what happens
     
  11. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello Mike2k9,

    I was looking for that CLSID also, but just gave it a try and it opened showing all drives on the computer.

    I'll have to look into it further.

    wt.pm,

    If you want and Explorer to on a particular drive, navigate to the c:\windows directory, drag explorer.exe to the desktop and choose Create Shortcut.

    For it to open the root of the c: drive automatically expanded, right-click on the shortcut, choose properties and type in /e,c:

    EG.

    C:\windows\explorer.exe /e,C:
     
    #11 reghakr, Jun 20, 2009
    Last edited by a moderator: Jun 20, 2009
  12. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Have you tried opening accessories from the Start - All Programs. and right clicking the windows explorer there?
    It should have the option to pin to the taskbar
     
  13. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Dave, it's not there, at least not on my pc.
    Reg, and Mike, I know how to change default opening location, that's not my problem, which is I can not get the icon's to show up on the taskbar, it's as blank as the Mojave desert. I have tried everything I know to try, everything I have found on the internet, nothing will make the icons pin to the taskbar.
    Mike, I would be happy with the jump list, if I could get just one icon to show up.

    Ok, two more screenshots, showing that there are no icons pinned, and the two things that happen when I try to drag something to the taskbar. I also included the original shot, with the task manager already pinned (which has disappered). If I right click on an icon, and then click pin to taskbar, nothing happens, and I do mean nothing.

    I am going to say that the program is corrupted. I have tried two system restores, and neither one helped.

    edit; I have actually added the quick launch back, temporarily until I can get this issue fixed, if I can get it fixed. I'm not one to give up, but there comes a time when you are just spinning your wheels and getting no were, and wasting your time. As long as there are options I am going to keep trying, but I think I have about ran out of things to try. Unless someone knows how to repair the corrupt files.
     
    #13 wt.pm, Jun 20, 2009
    Last edited: Jun 20, 2009
  14. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    wt.pm

    Sorry man, i'm outta ideas. Only thing i can tell from one of the above pics (3) is that you are dragging Windows Explorer to the pinned Task Manager icon and that's why you get the red circle. The first pic seems to work like it is supposed to, but the second pic baffles me.

    Did this location not help any?
    C:\Users\{your user name}\appdata\roaming\microsoft\Internet Explorer\quick launch\User Pinned\TaskBar

    reghakr

    The intent of the target path with the CLSID is to open Windows Explorer to My Computer (all the drives) instead of the default location of Libraries, which wt.pm is already aware of so that point is moot.
     
  15. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Have you, by chance ever tried to remove the shortcut arrows, either with a manual edit or customising third party software, by removing IsShortcut registry key. This is often the cause of your problem.
    Assauming for a moment, that you have,then you should re-add the IsShortcut registry key back to .lnk If you still do not like the shortcut arrows, then this is how to remove them BUT keep the pin option.
    Open a command prompt (Run as Administrator), and type the following command line to add the needed registry key:

    REG ADD “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Iconsâ€Â￾ /v 29 /d %SystemRoot%\System32\shell32.dll,50 /f
     
  16. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello wt.pm,

    Did you try my suggestion # 9?

    You need to close all open open windows and make sure the pinned Explorer shows up directly to the right of the the Start button.
     
  17. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Thanks, mike I am outta ideas tool. First pic, it says pin to explorer, there is no explorer icon to pin to, and if you do try to pin it, it just disappears. Third pic, I was actually trying to get between the task manager, and firefox icons, because it was trying to pin to start menu. The second pic is what I am seeing every time I try to pin anything, this is what is actually happening in the other two pics.
    Yes I tried the user/pinned/taskbar, does nothing, it shows up in the folder, but not the taskbar itself.

    reg,
    I have closed all windows, but to do the screenshot I had to have something opened. However what you see in the screenshot is what I see with nothing opened.
    Number 9 did not work, I tried several times.

    dave,
    I did add the reg key, even though I did not remove the arrows, or "shortcut to".

    As I said, I am just going to use the quick launch for now. And keep looking for a reason. I saw another post here about the icons being corrupt, but it did not actually have any information in it.
    I am googling, and yahoo, and msn, and all the other search engines looking for something about the icons being corrupt to see if I can find a fix. :confused:

    :DThank you to all of you that have tried to help. I do appreciate it. :D

    Edit; Link to other post
    http://windows7forums.com/windows-7-support/6242-taskbar-icons-possibly-corrupted.html
     
    #17 wt.pm, Jun 20, 2009
    Last edited: Jun 20, 2009
  18. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    The tech in me won't let this go. In better trying to help understand what is going on:

    Understand that any open folder is considered "Windows Exsplorer"; in this case, the folder named Taskbar is Windows Explorer.

    The folder that is open (folder named Taskbar) is where it is pinning the shortcut to the c: drive to. Because it says pin to explorer, that means it is adding that location to the Windows Explorer Jump List, so it essentially does not disappear, but if the Explorer icon was on the taskbar you could right click it and see the Jump List to the c: drive.

    Dont forget to enable jump lists the 2 options in the Start Menu properties must be selected as I noted in an earlier post.

    If you right click that folder (the folder named Taskbar) are you saying you do not have the option to Pin to the Taskbar or Unpin from the Taskbar? And if you do have either of those options, they both do nothing?

    If you close all folders you are saying that the Windows Explorer icon is "not" on the taskbar?

    I know I may be unclear and im sorry but i didn't realize how tough this is to explain in text :( but I am really want to make sure I have a complete understanding of what is going on.
     
    #18 mike2k9, Jun 20, 2009
    Last edited: Jun 20, 2009
  19. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Mike, I feel the same way, and I appreciate you still trying.

    1. Those options are checked.
    2. When I navigate through the actual C: menu to the taskbar folder, (a) the icon will be there. (b) I can click unpin and it disappears (c) when right clicking, it already says pinned to taskbar (hence - unpin) (d) if I drag the icon in to the taskbar folder, it shows up on the folder, but not the actual taskbar. (e) if I drag a explorer icon in the folder, then drag another explorer icon into the first icon, it still does not show up
    3. That's right, close everything, no icon

    [/quote=mike2k9]I know I may be unclear and im sorry but i didn't realize how tough this is to explain in text[/quote]

    Me either. I thought several times I had explained correctly, but without facial expressions, or hand gestures, or voice inflection some things just don't come across completely. Even using pic's, if you can't point to what you are talking about it just does not make sense.

    Hopefully, this time I have explained completely. I am still working on this end, I am just using a workaround until the mystery is solved. (scooby-do where are youuuuuu).lol
     
  20. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    Well this is a dead subject, I have had to reinstall, so now this works correctly. Thanks for the help.
     

Share This Page

Loading...