Possible Temporary fix for Ethernet disconnects

Discussion in 'Windows 7 Networking' started by Milikan, Jun 11, 2009.

  1. Milikan

    Milikan New Member

    Joined:
    Jun 3, 2009
    Messages:
    10
    Likes Received:
    0
    Ok, So I've been having the Ethernet disconnecting. I often was when I had multiple applications running at a time, getting Webpages/Streaming/downloading from the net. Haven't had a chance to try LAN yet. so dunno if that would have done it too. But the Ethernet would disconnect, In the Start it fixed itself but it doesn't anymore. Have to reboot if it happened.

    Well I'm am definetely not a pro at managing The Network adaptor. but I was sure it was The Ethernet which was the problem. My router seemed to be online all the time.

    I am running a Asus P5N-T Deluxe Motherboard with Nforce 15.35 Nvidia drivers. Its a 780i Sli board
    Cpu: E8500
    GFX: Nvidia Geforce 8800 GT
    Ram: 2x2 GB Corsair Dominator 1066
    HD: Some random Western digital/Hitachi.

    *edit: Ohh and the Windows i'm running is Windows 7 7100 RC x64

    Well I got into the Network Adaptor, And looked inside the properties of My local Area network Connection.
    I looked under the Advanced settings.

    I tried changing some of those settings that sounded relevant. (yea I'm going in the dark with this)
    First if u change some of those I'll recommend writing the default settings down before, so u can go back. (Ain't that rule number 1 for Troubleshooting)
    I had windows hanging the first time i did it, as it was updating the changes. The net wasn't working. Reboot > The advanced tab was gone? > Roll back driver. Net didn't work still > Uninstal Driver > Windows was hanging again > Reboot. The Network adaptor got installed again as windows started. Net is up again. But the Advanced Local area was back to default. Between these processes i gave the computer a litte time each time to finish the attempt

    Tried changing one of them at a time now, and clicking close accept. and the updating process seemed to finish this time.

    Ok The ones i changed goes like this.
    Low Power idle mode - From Enabled > Disabled
    Low Power Link Speed - From Enabled > Disabled
    WakeOnLan from PowerOff - From Enabled > Disabled

    Well I have been trying to create a disconnect error for an hour now, so this is not certain its a fix. But have been Streming 2 IE Tabs, 2 Firefox Tabs. Utorrent running. And it hasn't disconnected yet. So it looking like it did something at least. I think maybe the net is a little slower when all this is up. but at least it doesn't disconnect.
    I hope this works. and i hope maybe this can be of use to someone.

    I'll report back after some time to let you know if I have gotten another disconnect.
     
    #1 Milikan, Jun 11, 2009
    Last edited: Jun 11, 2009
  2. kermi

    kermi New Member

    Joined:
    Jun 11, 2009
    Messages:
    8
    Likes Received:
    0
  3. Milikan

    Milikan New Member

    Joined:
    Jun 3, 2009
    Messages:
    10
    Likes Received:
    0
    Damn just had a disconnect, as usual. This time a server refresh in steam did it. Crap so this doesn't work.

    Thx for the reply' I'll try what u wrote.
     
  4. Milikan

    Milikan New Member

    Joined:
    Jun 3, 2009
    Messages:
    10
    Likes Received:
    0
    Well doing as the link, made a weird incoming connections thing come on the network adaptors. thats didn't look very normal, so i reversed it. Back to normal. Now I found a guy saying that It could be that you just have to disable ipv6 on the local area network. So i have done that now. Lets see what happens. :)
     
  5. kermi

    kermi New Member

    Joined:
    Jun 11, 2009
    Messages:
    8
    Likes Received:
    0
    that's odd.. i dont recall it doing anything like that... My memory could be flakey on the matter though.
     
  6. halcion1

    halcion1 New Member

    Joined:
    May 13, 2009
    Messages:
    48
    Likes Received:
    6
    Do you show "unidentified network?"

    this will fix that:


    Check to see if you have this little devil in your services list:

    "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##"

    If you do, stop it and disable it. It is actually the Bonjour DNS Responder Service, and I believe it is the cause of the "Unidentified Network."

    The Unidentified Network disappeared after stopping this service and a quick disable/enable of the NIC, restoring Internet access.

    I Actually just rebooted, edited this post, and then re-enabled the offensive service to see what would happen...Immediately after enabling the NIC and this bastard service, the "Unidentified Network" returned...stopped it, disabled it, disable/enable NIC...Internet back up and running and no "Unidentified Network." (woot - woot!)

    Hope that helps! I haven't had issues since...
    :razz:

    FYI - I experienced this in both build 7100 and 7127...I am running 7127 now x64 - and discovered this fix just last night...so far so good just rebooted and then edited this post...I believe this fix will solve 7100 build issues too; however... I have not tested 7100 again yet.

    ...I also re-enabled Win 7's Discovery Mapping services, but always leave IPv6 disabled just because I am not using it.

    ...another two reboots, and a hard disk addition, and no problems with the Internet! - If you tried another fix such as changing the address of your network adapter, under "Advanced" - this is not necessary...I set mine back to "Not Configured." Everything is working fine as long as the Bonjour service is not running...

    My system:
    ASUS P5E
    Quad Core Q6600
    4GB Corsair Dominator DDR2
    NIC: Marvell Yukon 8E8056; driver v10.69.2.3 (4/21/2009)
    ***fyi - i did update the default Windows driver with this, Vista x64 driver

    For the record, there is some blame pointing towards the following software, of which I do have installed and running properly:
    Office 2007 SP2
    Adobe CS3 (updated current)
     
  7. Crosus

    Crosus New Member

    Joined:
    Jun 21, 2009
    Messages:
    2
    Likes Received:
    0
    Bonjour Fix Confirmed

    I just wanted to confirm, uninstalling Bonjour fixed my NIC Card from disconnecitng all the time. Often a restart would fix it, but the issue would return.

    I uninstalled Bonjour and have not had problems since.


    Anyway to notify apple on it?


    I am using Windows 7 64 as well.

    Thanks for adding this issue in the forum Milikan, saved me some time thats for sure.
     
    #7 Crosus, Jun 21, 2009
    Last edited: Jun 21, 2009
  8. testor

    testor New Member

    Joined:
    Aug 2, 2009
    Messages:
    16
    Likes Received:
    0
    On a fresh installed Win 7 RTM i dont have any Bonjour Service but i also get disconnected from Internet! So it cant be it in my case.

    couldnt find any fix yet for my probs. having all the new drivers. Ive tried behind router and without router its the same problem. I think its some softwareconflict or a bug from win 7.
    I have nvidia onboard lan. A friend got intel onboard lan and he dont have this problem.
     
  9. davzarek

    davzarek New Member

    Joined:
    Apr 28, 2010
    Messages:
    4
    Likes Received:
    0
    DC nic issue

    I actually had an issue with google chrome on several w7 installs - just uninstall/restart/reinstall google chrome

    TBH it could be any program that fiddles with the tcp/ip stack.
     

Share This Page

Loading...