printer settings could not be saved error

Discussion in 'Windows 7 Networking' started by yak, Jan 8, 2010.

  1. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Hello,

    I'm running an HP 2600n printer. It works fine via USB, but I'm having problems setting it up for my home network. I have another computer running XP, whereas my main one is Win 7 Home Premium. Both computers are running fine on the Internet. When I select devices and printers, I right click on the printer icon [I made a separate one from the USB printer setup and called it Network Laserjet2600n] and select Printer Properties. Under the Sharing tab, I checkmark Share this printer under the share name of Network Laserjet2600n. I'am in administrator mode. When I click on Apply, it comes up with "Printer Settings Could Not Be Saved. Operation could not be completed (error 0x000006d9)"

    Any ideas how to get the network on Printer going?

    thanks
     
  2. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Hello Drew,

    Firewall is turned off, as I use the router firewall. I'm using Avast and only have Resident Protection on.

    thanks
     
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    From A Quick Google SeARCH...............

    Suggestion 1:Temporary disable Windows Firewall service

    =========================

    a. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

    b. Right click the "Windows Firewall" service and choose Properties.

    c. Click "Startup type" option and click "Disabled".

    d. Click OK and share the printer again.

    If the issue persists, please proceed to the following steps.

    Suggestion 2: Verify Network settings

    =========================

    a. Click start and click Control Panel.

    b. Double click Network and Sharing Center.

    c. Select "Change advanced sharing settings" option in the right panel.

    d. Please turn on "Network discovery" and "File and printer sharing".

    However, if the error message still occurs, I recommend to reinstall the printer driver and reset the Printer Spooler for a test.

    For your reference, we can refer to the link below:

    http://support.microsoft.com/kb/2000007
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    yak:
    This is not a printer that you would typically want to share. Since it's a 2600n (the "n" designation meaning networking) The first thing you need to do is print a printer confirguration page from the printer itself to determine the IP address of the printer. This is usually done with a button or combination of buttons on the printer, check your manual or check hp's web site for how to print and printer configuration page. Once you have that information to should be able to interact with the printer through it's web interface. The first thing I would recommend doing once you're able to get into the printer is set a static IP addres for it and make sure it's outside the range of the DHCP scope handed out by your DHCP server, usually your router. Alternately you can use this information to do it with the printer buttons but it seems a little complex. http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=120&prodSeriesId=446153&prodTypeId=18972&prodSeriesId=446153&objectID=c00314350
    Once you've determined the IP address of the printer and set it to a static address so it doesn't keep changing on you then:
    Open "Devices and Printers" and select (highlight) a printer doesn't make any difference which one but if you have the 2600n installed pick it now and it will save you some steps later.
    Now on the sub menu bar above select "Print server properties"
    Select the "Ports" tab
    Then the "Add Port button"
    Select "Standard TCP/IP Port"
    Then the "New Port" button
    Then next
    In the "Printer Name or IP Address" box, enter the IP address that you know from the previous directions.
    The "Port Name" box should auto populate with the correct information
    Leave the next window set to "Generic Network Card"
    Click Next and finish
    Now either confirm that your printer is using this new TCP/IP printer port by right clicking the printer and choosing "Printer Properties" not "Properties".
    Go to the "Ports" tab and make sure that the TCP/IP printer port is checked.
    Or
    Install your printer as a local printer using the latest drivers for your version of Windows 7, here http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?lang=en&cc=us&prodNameId=446154&taskId=135&prodTypeId=18972&prodSeriesId=446153&lang=en&cc=us&submit=Go%20»»
    and direct it to use the TCP/IP printer port.
    No need for sharing each computer shoud be able to print using this method and "Simple TCP/IP Printing"
     
    #4 Trouble, Jan 9, 2010
    Last edited: Jan 9, 2010
  5. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Thanks for your response Randy,

    I have tried as per the initial response posting and your posting, but I keep getting the error
    coming up when I try to share the printer. I did successfully add the printer port (TCP/IP)
    and used the IP address from the printer configuration printout. I did also remove all the printing devices
    and reinstall them again. No problem when using USB Port, just the TCP/IP Port. I don't know what else to try right now
     
  6. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Also thought of something else. Could the router settings be involved in this?
     
  7. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Found the problem. It was an intermittent network cable from printer to router. Printer is sharing now.
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Whoa, who'd'a thunk it. Glad to hear you got it working, man how did you find that. Any way thanks a lot for posting back and letting us know how you fixed it.
     
  9. kokluxe

    kokluxe New Member

    Joined:
    Feb 6, 2010
    Messages:
    4
    Likes Received:
    0
    Error 0x000006d9 on a shared printer in Windows 7

    You can marked this issue as solved!
    The offending program causing this error is Windows Firewall, here's what you need to do to resolve this issue....
    If like me you have disabled windows firewall, I use Comodo Internet Security, you need to re-enable the Windows firewall in order to share the printer.

    If you have disabled or turned off Windows Firewall. (and this error in my case was caused by exactly that and EXACTLY this Error code)
    Step #1 - Disable any other firewall you may have installed. Stop it from loading at boot and restart your PC.

    Step #2 - Go to the Admin Tools Folder >> Services >> Windows Firewall >> Double click and either set it to Manual or Automatic and Save.

    Step #3 - Open Control Panel >> System & Security >> Windows Firewall >> Turn Windows Firewall On or Off >> (Enable) Turn on Windows Firewall >> Save
    Then go to Restore Defaults >> Click Restore Defaults Button >> Save
    (you only need to do this IF you changed any settings for the firewall, but it's still a good idea and will ensure there are no problems when proceeding)

    Step #4 - Click Control Panel Home >> View Devices & Printers >> Select/Click your Printer >> Display Printer Properties >> Sharing >> Share this Printer >> OK

    Step #5 - Go Back to Windows Firewall and Turn it back off >> Save

    Step #6 - Go Back to Services >> And set Windows Firewall to Manual (or disable if you prefer, I recommend disable to prevent conflicts with preferred firewall you are using.)

    Step #7 - Restart & Re-enable your preferred firewall to start at Boot >> Reboot
     
  10. yak

    yak New Member

    Joined:
    Jan 7, 2010
    Messages:
    16
    Likes Received:
    0
    Hi,

    I have a hardware firewall via router (no software firewall, Windows Firewall was turned off) and replacing printer cable with new one fixed the problem.
     

Share This Page

Loading...