Really (!) disable WISPTIS.EXE service (or program?)?

Discussion in 'Windows 7 Help and Support' started by pstein, Jun 29, 2016.

  1. pstein

    pstein Honorable Member

    Joined:
    Mar 20, 2010
    Messages:
    347
    Likes Received:
    0
    I disabled the "Tablet PC Input Service" in Services management console for a Desktop 64bit Win 7.
    I guess this is the underlying service for WISPTIS.EXE

    Now when I start some other tools like "Toad for MySQL" then this program is started automatically anyway.

    It is running as

    C:\Windows\System32\WISPTIS.EXE /ManualLaunch

    Since I found no option in Toad.exe it must be started automatically by Win7 itself.
    Even worse: After exit of Toad WISPTIS continues to run.

    Why ?

    Why is disabling a service not enough?

    Maybe it is run not as a service but as a "normal" program?
    On another Win 7 computer it is NOT started when Toad is launched.
    Very strange

    How can I really, really get rid of this WISPTIS.EXE start?

    Can I simply delete it?

    Peter
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    I'm not sure but maybe your Toad program is for some reason calling for onscreen keyboard support or something similar, I would ask the authors of the program about that. Don't delete wisptis.exe, instead add an Everyone-Deny permission on the Execute attribute of the file only.
     
  3. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    Oh before you do the above, you could try going to Languages and Settings in control panel and make sure you don't have an alternate input device that may require wisptis.exe to be running to use.
     

Share This Page

Loading...