Remote Desktop Connection can't connect on LAN - both are Windows 7 machines

Discussion in 'Windows 7 Networking' started by derning, Oct 1, 2010.

  1. derning

    derning New Member

    Joined:
    Oct 1, 2010
    Messages:
    10
    Likes Received:
    0
    Hi guys, thanks in advance for any help you could provide.

    I have two Windows 7 machines, a laptop and a desktop.
    • Both have Remote Desktop Connection enabled.
    • Both have "Enable connections from any version of remote desktop" turned on.
    • Both are connected via ethernet LAN to the same router.

    When they try to connect to each other via RDC:
    • DESKTOP can rdc into LAPTOP without a problem.
    • LAPTOP cannot rdc into DESKTOP.

    I have tried using the DESKTOP computer's name, and then I tried the IP address as well.

    Below is a screenshot of the error message I get. Any ideas what I should try next?

    rdc error 01.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    There are inbound rules within the windows firewall which govern Remote Desktop, so for the time being disable the windows firewall and uninstall any third party firewall applications and/or third party antivirus / internet security suites from the Desktop for debugging, you can always reinstall them later. Are both machines running Windows 7 Pro, Enterprise or Ultimate? Can you ping the desktop from the laptop by both IP and HostName?
     
  3. derning

    derning New Member

    Joined:
    Oct 1, 2010
    Messages:
    10
    Likes Received:
    0
    Thanks, Trouble.

    All machines are running Windows 7 Ultimate. All machines can ping each other, no problem.

    Per your suggestion, I've checked the inbound rules for Remote Desktop Connection. I see one private profile and one public profile. They are both enabled and set to "allow the connection." I also disabled the firewall, the antivirus, etc.

    Still the same problem.

    Here's another clue that might help narrow things down. I also tested it with other Windows 7 Ultimate client machines on the network. All the other machines can RDC to each other, no problem. The DESKTOP machine can RDC into all the other machines, no problem. But none of the others can RDC to the DESKTOP machine.

    What do you think? What should I try next?
     
    #3 derning, Oct 8, 2010
    Last edited: Oct 8, 2010
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It's a long shot but make sure you or perhaps someone else hasn't changed the default listening port from 3389.
    Type regedit into the search box and hit enter
    Drill down to the following key in the left colum
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp
    in the right column
    scroll down as necessary and locate the value for PortNumber
    make sure it is 3389 see attachment.
     
  5. derning

    derning New Member

    Joined:
    Oct 1, 2010
    Messages:
    10
    Likes Received:
    0
    Dude, you're brilliant! The port number was changed. Probably back when I was tinkering around trying to get multiple computers accessible via separate dynamic dns addresses.

    I changed the listening port back to 3389. Gonna reboot now. Oh man, I'm so excited.

    I'll report back in a few!
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, well it's been "a few".
    Hope everything worked out and your problem is resolved. If you can update your thread with a follow up, it would be appreciated.
    In any event, a belated welcome to the forums and we hope to continue to see you around.
    Best Wishes
    Randy
     
  7. derning

    derning New Member

    Joined:
    Oct 1, 2010
    Messages:
    10
    Likes Received:
    0
    BOOYAH! It worked.

    You are a supreme jedi master, and I bow down to your awesome powers, oh exalted one.

    Seriously, thank you so much for your help!
     
  8. derning

    derning New Member

    Joined:
    Oct 1, 2010
    Messages:
    10
    Likes Received:
    0
    ... and thank you for the warm welcome. I'll be peeking in here as well to see if there's anything I can help some other members with.

    Have a great weekend, Randy.
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Oh Oh, now you've gone and done it. Next people will be asking that I help them retrieve their space vehicles from swamps and help them blow up Death Stars.
    "No! Try not. Do. Or do not. There is no try."
    Yes, please. All participation and offers of help are gladly accepted here.
     
    #9 Trouble, Oct 9, 2010
    Last edited: Oct 9, 2010

Share This Page

Loading...