"Replace all Child object permissions with inheritable permissions from this object" will not stay c

Discussion in 'Windows 7 Help and Support' started by chrispcall, Feb 28, 2010.

  1. chrispcall

    chrispcall New Member

    Joined:
    Feb 28, 2010
    Messages:
    4
    Likes Received:
    0
    Backstory: I have been using Win7 since 7000 beta and played with it and love it (I'd consider myself pretty PC-saavy). But I'm having a problem with homegroup sharing on two computers.

    I have a desktop running much like a server: having utorrent download (free and legal) torrents and copying them into a folder on my desktop once they're fully downloaded. (To be clear, utorrent is copying them after download...)

    I have that folder called "test" being shared with my homegroup.

    The problem is: when the file is copied over from uTorrent, it has the lock icon and can not be seen by the laptop on the network (while all the other files in the directory can be). If I go into the permissions settings for the folder, this is what it looks like:
    FolderPermission&#.

    If I try to select the "Replace all Child object permissions with inheritable permissions from this object" checkmark, it flashes and then unchecks itself and it LOOKS like nothing changes but all files with locks are now accessible through the homegroup. However, as soon as uTorrent drops another file in, the new files have the lock icon again.

    This is what my ownership looks like: (I am a local admin and "Chris" is my username)
    FolderOwnership..

    I've tried looking and trying everything from taking ownership to all parent directories from every possible scenario I can think of to make this work. The crazy thing is I had it working fine through sharing it as a network share the old-school way, but I really wanted to use the homegroup since it works so well for sharing our other music and video files. It just seems to be this that's not working. (Maybe utorrent is putting the file in with different permissions...?)

    Well, I just Downloaded another file to see what it looks like before and after. Here is the permissions of the file (not the folder this time) as it looks as soon as it's copied and the lock is still on:
    FilePermissionsW.

    and the ownership of the file as it looks as soon as it's copied and the lock is still on:
    FileOwnershipWit.

    Finally, this is what the permissions looks like for the file after I've selected "Replace all child..." and it flashes and unchecks that option (Again, this also removes the lock for all of the current files in the folder, but no future files.):

    FilePermissionLo	.
    (Ownership didn't change so I didn't upload the photo)

    Obviously checking that box adds permission to the group "HomeUser" but it will not carry forward for files placed in that folder at a later point. I've tried adding "HomeUser" as owner and that doesn't stick. It's in the permissions but it says <not inherited> so I'm assuming that may have something to do with it but nothing seems to make it stick.

    Hope this helps narrow it down. Sorry for all the images and the long post, I just want to be thorough... Thanks in advance for any help you guys can provide and have a great day!
     
  2. millstone

    millstone New Member

    Joined:
    Apr 16, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem

    Did you ever get a resolution to this - I am getting exactly the same issue
     
  3. chrispcall

    chrispcall New Member

    Joined:
    Feb 28, 2010
    Messages:
    4
    Likes Received:
    0
    Fixed mine

    I did. It was very stupid, actually, but I was relieved to have it figured out...

    Please let me know if this was your problem, as well.

    My problem came from the fact that uTorrent saves file in a certain directory and I was having uTorrent move the torrents (as they were being completed) to my home group "shared" folder. The default folder that uTorrent was saving my files to was not set up to share or have any special permissions.

    So, every time a file was downloaded, it was downloaded into the "downloads" folder which tagged the files with their permissions (just the user level that did not have access to the home group). Then, when it moved the completed files to the home group shared folder, the permissions were already embedded in the file and it could not be accessed via the home group.

    My solution was to also share the folder where the files were being downloaded to, and then have uTorrent move it to the "Finished Downloads" folder that was also shared. (I opted to name it "Finished downloads" so the GF would not try to grab the files while they were being downloaded.) Now everything works flawlessly, like the files are being loaded onto each PC for viewing whenever I want. It really works out great.

    Good luck. I hope this helps someone in the future...
     
  4. ironwings

    ironwings New Member

    Joined:
    Aug 27, 2011
    Messages:
    2
    Likes Received:
    0
    You seem to have a very good grasp regarding the "Replace all child object permissions..." and I was wondering if you could please help me. I clicked on that checkbox and now I can't open my Windows Explorer. All my icons on the desktop turned white like they are Notepad icons. It seems like the path was changed. Now, my computer is trashed and all my files for school and work. Please help me. Buying another computer will just fix my need for a computer but the problem is, the files on the broken computer are needed for school and work. Please help!!!
     

Share This Page

Loading...