SATA disk noise... Win 7 only

Discussion in 'Windows 7 Hardware' started by nandemonai, May 19, 2009.

  1. nandemonai

    nandemonai New Member

    Joined:
    May 19, 2009
    Messages:
    6
    Likes Received:
    0
    Hiya guys,

    Now, many of you may call me crazy but let me assure you, I know my way around computers pretty darn well, both hardware and software but this is really quite an odd issue.

    Since the RC release I've been testing, as we all have. Honestly, to me, Win 7 so far looks like XP with a theme and some minor GUI improvements but hey whatever floats your boat :p

    Onto the issue..

    I have a triple boot system on two drives. 1st drive is a 120G system disk (Ubuntu ext3, XP NTFS and Win 7 NTFS). 2nd drive is a 720G data drive (1 partition, NTFS). Both are WD drives.

    For the first week or so things were fine, but recently my data drive has been making an odd noise when accessing the data drive, getting progressively more frequent. It's a noise I've not heard before and I've heard my share of failing disks.. this is different.

    What will happen is, even when spinning fine (ie it's not spin up sound) I'll try and access a directory or file on the drive and it lags for about 1-2 seconds while making a 'bzzz' sound. It's hard to explain but it's more of an electrical sound than a metallic one if that makes sense. I'm certain it's the drive data as it's always when accessing something on this drive with a corresponding delay. It actually almost sounds like the drive spins way too fast for a second or two. That's the best way I can describe it.

    Now, normally I'd chalk it up to hardware as that's certainly what it sounds like BUT.. this has NEVER happened on either Ubuntu or XP. Not once.

    The drive is not fragmented (3%ish at the most), it passes chkdsk fine with no errors, even passes a surface scan with no bad sectors. I've run S.M.A.R.T. diagnostics on it and also no errors to report there. Not one.

    Thing is, it was fine until the last few days. There are only two things I can think of that have happened recently that _could_ be related. The first was a sleep issue, Win 7 doesn't like my motherboard (Asus P5Q Delux) and when I tried to suspend a few days ago, it crashed big time, thrashed the disk (I'm assuming it was the system disk) and seized. Wouldn't reboot then on a cold boot the machine refused to pass POST. Tried everything, complete power down, reset etc but it just wouldn't boot. I ended up having to reset CMOS and then finally my machine would function again (Found some people with the same issue on similar boards with Win 7, dodgy drivers I'm assuming).

    After setting up the BIOS again and being sure not to ever touch sleep again (heh even Ubuntu can sleep this machine fine) the machine was fine again but then a day or so later this HDD issue started. The only other thing I've done with the data drive since then was install a game on it. That's it.

    So does anyone have any suggestions? Ideas what it could be etc?

    I'll reiterrate again that this only ever happens in Win 7. XP / Linux accesses the disk fine.
     

Share This Page

Loading...