Server 2016 Cannot Install Cumulative Security Updates

Hi everyone! I've been trying to solve this issue for a while now and it has me ripping my hair out so I hope someone can assist.

I have a client with a Windows Server 2016 system on bare metal. It's been fine since 2017 but in the last couple of months, it's been failing to install monthly Cumulative Updates for Windows (.NET is fine.) The update will install, it will reboot, the update will fail and it will have to reboot multiple times to undo it. Since this is a bare metal server, this process can take up to 2 hours per attempt.

I've tried all the standard solutions. The Windows Update Troubleshooter, multiple DISM commands, SFC, killing the update cache etc. I've also tried creating a fresh administrator account and running the update through that. Nothing has solved this. I took fresh CBS and WindowsUpdate.log files (attached) and I can see errors in them (I've also been told they're registry related) but I can't make heads or tales of where to try to start troubleshooting to resolve the issue. This server runs a number of things and reloading it from scratch would be a monumental undertaking I'd really rather avoid. I know when Windows Update gets stuck in this install/undo loop, it can sometimes be really gnarly to resolve but I'm hoping someone can help me pinpoint this down. I've successfully fixed this kind of issue before but I've never seen it be as stubborn as it is on this server.

Thanks everyone!
 

Attachments

  • Logs.zip
    752 KB · Views: 54
Top