"Set as desktop background" for image files

rronaldson

Senior Member
#1
I've noticed that if I right click a jpg file I don't get the "set as desktop background" option in the context menu. I do for bmp and jpeg files so why not for jpg? It's not a problem as I can get around it but I'm just curious about why this should be so.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Are there any specifics on the file/files you are trying to use? My .jpg file does show the background option. Maybe yours are a resolution or size which are not acceptable.

If you go to the start menu, all programs, Default Programs, and check the Set Associations, do the .jpeg and .jpg extensions show with the same associations?
 


rronaldson

Senior Member
#3
Thanks Saltgrass. I don't think there is anything particular about the jpg's to preclude them being acceptable. If I open them with Windows Picture Viewer and right click the displayed image I get the background option. I've checked Set Associations and they are the same for jpg and jpeg.
 


rronaldson

Senior Member
#4
Been playing around with this as my last answer gave me some ideas. I usually have all my image formats associated with Picasa Photo Viewer. If I make Windows Photo Viewer the default program for jpg then I get the set background option in the context menu. If I set it back to Picasa then I lose it again. However both bmp and jpeg are also associated with Picasa and the both have the set background option. Interestingly jpeg also has the rotate options.
 


rronaldson

Senior Member
#5
Further :) I've disassociated Picasa Photo Viewer from image files and now they've reverted to Windows Photo Viewer and context menus have changed as well.

jpg now has set desktop
jpeg has set desktop (twice) and rotate options
bmp has set desktop and greyed out rotate options

Interesting ........
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.