Windows 7 "Sid Meier RailRoad" 's problem

Discussion in 'Windows Games' started by Acarie, Aug 27, 2010.

  1. Acarie

    Acarie New Member

    Aug 27, 2010
    Likes Received:
    I am running Win7 64bit, Q6600 CPU, 8G Ram with ATI4870 display card.
    I love the game "Sid Meier Railroad" and still wish to play it, tried several method such as running in XP service Pack 2, win95, win98 and even win2000 compatiable mode, BCDedit string editing, largeaddress aware patch for the EXE file, clear all the map directory and download another set of map from SMR's website and even Virtual PC 2007. However, all the above didn't make it.

    Actually, I manage to run the twice. The situation is, I run the setup.exe in XP SP2 mode. I change the compatible mode to XP SP2 upon the completion of install and run.
    It start running and successful get into the game. However, that is the only time the game running. It didn't run anymore even I quit the game from the game menu until I uninstall the game and re-install again.

    Please advise if there are anything I can do with this problem.
    Thanks in advance.

    1. The game does start to the menu, which the menu with single play, tutorial ...etc. But it CTD during the loading screen to the game.

Share This Page