Slow Directory display on USB disk

a w

Active Member
#1
I have a Seagate Backup Plus 8TB Desktop USB External Hard Drive on my Win 7 ASUS G73S laptop .
It works well , just for one problem . If I don't access a directory on it for a few minutes , then when I do , the file display can take quite a while to come up , while I get a slow advancing green bar on the top of the Explorer window showing directory path . If I click to resort according to date etc. , same thing .
In the Advanced Options of directory properties , I have selected indexing , but doesn't seem to help .
Thanks .
 


Digerati

Fantastic Member
Microsoft MVP
#2
See if this helps:
  1. In Windows Explorer, right click the drive, then select Properties,
  2. Select the Customize tab,
  3. Under Optimize this folder for drop down menu select "General items",
  4. Check "Also apply this template to all subfolders",
  5. Click OK.
Now try it.
 


a w

Active Member
#3
Thanks Digerati !
This appears to have worked !
Could you give a simple explanation about this , please ?
Thanks .
 


Digerati

Fantastic Member
Microsoft MVP
#4
What happens is Windows attempts to create thumbnail images of files it finds in Windows Explorer (now called File Explorer in W10) if it finds (or believes) there are image files in that folder. This can actually be very handy if you are looking for a specific image but, for example, your camera names all the images based on the timestamp the image was taken - that is, not descriptive at all. If you have a lot of photos and video files, tunes (with album art embedded within) and other files that may contain images, Windows can get bogged down creating those thumbnail image files - especially on hard drives (which are slow compared to SSDs) and external hard drives which are often slower still. By telling Windows to treat the folders like they contain just "General" items, it does not waste your time generating all those unique thumbnails.

At least that is my understanding of all this.

This is also a common problem displaying the Downloads folder so you may need to do it there too. And note for some reason, this setting does not always stick as Windows may change the setting again if you download more files or save more files to your drive.
 


Last edited:

a w

Active Member
#5
OK , that makes sense .
Thanks Digerati .
 


Digerati

Fantastic Member
Microsoft MVP
#6
No problem. Glad that sorted it out for you.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.