[SOLVED] Cannot delete file, cannot take ownership, cannot even read permissions !

Discussion in 'Windows 8 Help and Support' started by ErPl, Jan 8, 2016.

  1. ErPl

    ErPl New Member

    Joined:
    Jan 8, 2016
    Messages:
    2
    Likes Received:
    0
    There are a lot of threads on files or directories with access or deletion troubles, but this problem seems a little different, because apparently even the machine Administrator doesn't have Read permission on this file.

    In Windows 8.1, I created this .avi file and something went wrong when deleting it, here are the symptoms:
    - It is listed in Windows Explorer, I can select it and delete it (SHIFT+DEL) and no error message appears, but when I hit refresh, it is still listed in the directory.
    - In a command prompt (opened as admin), typing "del file.avi" gives "Access denied" message, same as "TAKEOWN /F" command, same as "ISACLS /reset" command.
    - Back in Windows Explorer, if I select the file, right-click, Properties, I can see it's not encrypted (in Advanced attributes the option "Encrypt contents to secure data" is unticked), and in the Security tab I just have the message "You must have Read permissions to view the properties of this object", I can click the advanced button in that tab, and in the Advanced Security Settings window, the three tabs (Permissions, Auditing, and Effective Access) display the same 'must have Read permissions' message, along with a button to attempt to obtain said permissions. Of course, that fails, it tells me "You do not have permission to view or edit this object's permission settings."
    - I tried a Microsoft Fix it program from Microsoft's support site (kb/2623670/en-us), which fixed some corruption in the recycle bin, but the file is still there and nothing changed. Now it tells me that "no problems need attention"

    There's a post similar to this one: "Access Denied Error Message Trying to Delete Folder Even in the DOS Command Prompt!", but he can take ownership (TAKEOWN command) of the directory he's trying to delete (and he's in Win7).

    Any suggestions ?
     
  2. ErPl

    ErPl New Member

    Joined:
    Jan 8, 2016
    Messages:
    2
    Likes Received:
    0
    Ha ! I could already hear some snotty reply like "Have you just tried moving the file?".
    Well, now I did, and it moved ! AND I could delete it from the new location !!!
    Problem solved.
     
  3. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
    Hi,
    I'm really sorry your thread was missed but glad you at least solved your issue.
     

Share This Page

Loading...