Sound Drivers For 7

Discussion in 'Windows 7 Hardware' started by kemical, Jan 23, 2009.

  1. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Creative has released a Beta 2.17.0006 driver specifically designed to provide support for the X-Fi Titanium series under Windows 7 Beta.

    If you own a SoundBlaster Audigy SE or another version of the basic Audigy model then used Windows Update to attain your driver. Creatives vista driver will cause blue-screens when used in conjunction with 7.


    More links for Drivers:
    http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&thread.id=135324

    http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&thread.id=135215






    I'll update this thread as and when new drivers are released..
     
    #1 kemical, Jan 23, 2009
    Last edited by a moderator: Jan 23, 2009
    Radenight and (deleted member) like this.
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Creative has released a Beta 2.18.0008 driver specifically designed to provide support for the X-Fi series under Windows 7 Beta. Note that this does not include the X-Fi Titanium series, which received a separate beta driver last week.
     
  3. Bladeripper

    Bladeripper New Member

    Joined:
    Jan 14, 2009
    Messages:
    24
    Likes Received:
    0
    mm thats odd i have an PCI Express X-Fi Xtreme Audio but cnt seemt to see anything under win 7 for that sound card :S
     
  4. kalik

    kalik New Member

    Joined:
    Feb 16, 2009
    Messages:
    4
    Likes Received:
    1
    Soundmax ad1888 driver problem solved!!

    HI !! You all must be having problem that windows 7 is not detecting soundmax driver on asus board. On installing from cd that came with motherboard it says OPERATING SYSTEM NOT SUPPORTED!! :mad:
    So the solution for this problem is.:D
    Download this zipfile from the link RapidShare: Easy Filehosting

    Extract the contents.

    Findsetup.exe in it. Now, right click on the setup and choose option Troubleshoot compatibilty.

    It will detect issues and search programs and you will be presented with a set of options.

    Choose option it ran with previous versions and also choose need special permissions.
    click next . And your setup should start.
    Let the driver install . restart when prompted and done enjoy music on you system.:cool:

    You may for first time get a Notification No ADI codec driver found.. Just click ok everything is fine.
    IMPORTANT. do not try to upgrade the driver from device manager or it will again return to No sound condition.:eek:
     
    1 person likes this.
  5. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Creative has released a Beta 1.04.0000 driver specifically designed to provide support for the X-Fi Xtreme Audio series under Windows 7 Beta.
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Creative has released a Beta 1.01.0091 driver specifically designed for USB-based SoundBlaster audio cards under Windows XP, Vista and Windows 7 Beta.
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Creative has released a Beta 1.04.0079 driver specifically designed to provide support for the X-Fi Xtreme Audio series under Windows 7 Beta.
     
  8. XCommandeRX

    XCommandeRX New Member

    Joined:
    Mar 14, 2009
    Messages:
    8
    Likes Received:
    0
    I choose winXP in previous version, and at the end of setup i got message "driver not found! restart computer and try again"
    mb - ASUS M2N DH, drivers from windows update works in 2-channel mode. i want 5.1 !!! Analog devices didn't release new drivers yet?

    also, i have one of first Audigy cards, and drivers from microsoft won't work at all. no sound from card, but driver seems to be properly installed, without any warnings|errors
     
    #8 XCommandeRX, Mar 14, 2009
    Last edited: Mar 14, 2009
  9. Krytpop

    Krytpop New Member

    Joined:
    Mar 19, 2009
    Messages:
    4
    Likes Received:
    0
    hey i installed the Drivers via the cd and when i open the audio manager it says its not suported by this OS, i tried your guide but said "drivers couldnt be found please restart " anyway. i have sound i can listen to music but it keeps crackling and sounding distorted and then it will be crystal clear
    it just keeps alternating between this -_- any idea whats up?
     
  10. NYdubber

    NYdubber New Member

    Joined:
    Mar 25, 2009
    Messages:
    6
    Likes Received:
    0
    Installed 7057 x64 on my m9040n no problems, but I'm having tons of issues with my HP zv5000.

    "This Pavilion notebook system offers high-quality, integrated, 16-bit Sound Blaster Pro-compatible audio, Harman/Kardon integrated speakers,"
    http://reviews.cnet.com/HP_Pavilion_zv5000z/4505-3121_7-30822949.html

    I tried the above method of "this used to work" and "needs special permissions" and none of the operating systems I selected work. They all say that the driver isn't compatible w/the OS I'm using.

    Any help? THANKS!
     
  11. quad300

    quad300 New Member

    Joined:
    Apr 12, 2009
    Messages:
    4
    Likes Received:
    0
    although sound works with my mobo (see sig), but only in stereo, Realtek driver said it's for vista only, I want surround sound to work. Audio hardware is ALC889a
     
  12. MikeEx

    MikeEx New Member

    Joined:
    Mar 15, 2009
    Messages:
    26
    Likes Received:
    0
    #12 MikeEx, Apr 17, 2009
    Last edited: Apr 17, 2009
  13. CrisMoreno

    CrisMoreno New Member

    Joined:
    Apr 19, 2009
    Messages:
    10
    Likes Received:
    0
    Hello there! I just installed "Working Sound Blaster X-Fi series Support Pack 1.0" on Windows 7. Now at least my Surround-Speakers work. But my Subwoofer still doesn't, if I play mp3s in iTunes or the Media Player. When I test my setup in the Console, the subwoofer works without any probs. Do you have any solutions, how I can get the subwoofer to work? Mp3s don't sound that nice without a little bit of bass! ;)

    Thanks, Chris
     
  14. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    kemical,

    Thanks

    That's excellent and the exact reason I uninstalled Windows 7 on my HTPC. I couldn't get 5.1 or 7.1 surround through my Marantz receiver using the SPDIF option. Who wants to watch a Blue-ray movie in stereo?
     
  15. CrisMoreno

    CrisMoreno New Member

    Joined:
    Apr 19, 2009
    Messages:
    10
    Likes Received:
    0
    Well after installing the Creative W7 Beta drivers and setting up THX, it worked. It just doesn't make any sense, that you have to go through the THX Setup to make your subwoofer work. But that saved my day.
     
  16. halshb

    halshb New Member

    Joined:
    Apr 23, 2009
    Messages:
    4
    Likes Received:
    0
    I installed win 7 build 7000. It seems ok except for the sounds. I've tried many ways but it still not work. any help?
    my MB is P5PE VM. Thanks for help!
     
  17. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    We need to know the manufacturer and model of your sound card.
     
  18. halshb

    halshb New Member

    Joined:
    Apr 23, 2009
    Messages:
    4
    Likes Received:
    0
    My motherboard is Asus P5PE VM. It uses driver Soundmax version 5.12.1.5410
     
  19. gizbug

    gizbug New Member

    Joined:
    Apr 24, 2009
    Messages:
    20
    Likes Received:
    0
    Creative Worldwide Support

    Quote:
    Beta Driver
    Creative Sound Blaster X-Fi Series Beta Driver 2.18.0013
    Filesize : 49.04 MB
    Release date : 24 Apr 09

    File Name : SBXF_W7DRVBTA_US_2_18_0013.exe

    This download is a beta driver providing Microsoft® Windows® 7 Beta support for Creative Sound Blaster® X-Fi™ series of audio devices. For more details, read the rest of this web release note.

    Take note of the following:

    * THIS IS AN UNSUPPORTED BETA DRIVER. There is no technical support for this driver.
    * We recommend that only experienced users install this driver. Do not install this driver on a system used to perform critical tasks.
    * Users who are looking for stable drivers should wait for the final release. When this happens, user should install the latest Sound Blaster X-Fi series driver available.

    This download supports the following audio devices only:

    * Sound Blaster X-Fi XtremeMusic
    * Sound Blaster X-Fi XtremeGamer Fatal1ty® Professional Series
    * Sound Blaster X-Fi XtremeGamer
    * Sound Blaster X-Fi Platinum Fatal1ty Champion Series
    * Sound Blaster X-Fi Platinum
    * Sound Blaster X-Fi Fatal1ty
    * Sound Blaster X-Fi Elite Pro
    * Sound Blaster X-Fi

    Added Features and Enhancements:

    * Enables Dolby® Digital Live and DTS® Connect features.

    Requirements:

    * Microsoft Windows 7 Beta
    * Creative Sound Blaster X-Fi series audio devices listed above

    Notes:

    * To install this driver
    1. Download the .exe file onto your local hard disk.
    2. Double-click the downloaded file.
    3. Follow the instructions on the screen.

    On their website
     
  20. Incolumis

    Incolumis New Member

    Joined:
    May 11, 2009
    Messages:
    4
    Likes Received:
    0
    i have the same problem, even when i'm scrolling through a website, or loading another page, or loading a program, it sounds distorted, even slows down the music sometimes
    i have an X-Fi Platinum, GA-965G DS3 mobo, 6600C2D, 4GB ram, 8800GTS
     

Share This Page

Loading...