Windows 7 sound problem on notebook


New Member
Jun 5, 2009

My sound works but after a while when my sound isn't used I see that win7 turn off the sound on my notebook. But when a program want to play a sound my notebook freeze until the sound is back on. How can I turn this off?
In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

1. Go to Start > Run, and type msinfo32. then expand the Conmponents tree and choose a device
2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it.
3. Download System Information Viwer
4. Download PC WIZARD 2008
4 Please fill out your computers specs in the User Control Panel here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.

The exact make an dmodel of your sound card would help us out greatly.
It has nothing to do with my soundcard or laptop. It works. I'm sure it's a feature in win7 to save battery.

After some time when no sound is played I see that the light of "no sound" turns on on my laptop. In the taskbar I see that my sound is not muted, it's only win7 that shutdown my soundcard. I want to disable that feature because it's anoying me more than it is good for.
OK, but if you had the right sound card driver, you would not have this problem.

If I'm getting this correctly, can't you simply mute the sound altogether?

For detailed info on laptop power option, go to Start > Help and Support and type in laptop power.

Or type in battery life. in Help and Support
I'm not muting the sound, it's win7 itself. It must be a battery saving feature like the one that dimms the screen after a while. I'm not having those problems on my desktop, only my laptop. I've looked where I can disable it but I don't find it. It's not in the energy scheme.

And it has nothing to do with the drivers, I have also reinstalled them.
Last edited:
Try going to Control Panel > :power Options, click the Change Advanced Power Settings link, scroll down until you see Display and you may change your options here.
It has nothing to do with the display, It's the sound. And I have already checked the advanced power settings before I started this topic. There is no option in there to disable it.
Sorry, i just answered a question regarding the display and thought you problem was the display//

it's Hell getting old:)

I believe the best source of information would be to go to Start > Help and Support and type in laptop power or battery life.
I found in the device manager for other hardware (like the fingerprint) the option that windows can turn off the device to save energy. The sound device doesn't have this option :(

Thanks for helping me but I'm afraid there isn't a solution for my problem.
Sorry I couldn't help you with your problem,

Although I still believe it to be a sound card driver issue.

Going to Dells site probably does not have the most updated driver for your sound card.

I always go to the manufactures site for Ex, (Nvidia) for the latest driver.
Could you give me the full make and model ofthe Soundmax driver?

Something like this:

Asus SoundMAX Audio Driver v
I could only find a lower version of that driver on HP's site.

ADI SoundMAX HD Audio Driver for Microsoft Windows Vista; (14 Aug 2007)

So it appears you are using the correct driver.

I've heard HP will not provide any Windows 7 driver until the final product is released.
Top Bottom