Start up error 339 Mswinsck.ocx on WIndows 7 64 bit

Discussion in 'Windows 7 Help and Support' started by rege0039, Jun 11, 2009.

  1. rege0039

    rege0039 New Member

    Joined:
    Jun 11, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    I have built a nice machine on RC1 64 bit Windows 7. Like it lots - but I keep getting two identical errors on start up which I know how to solve in xp or vista but not windows 7.

    On start up I get two idential pop up windows that say Run Time Error 339 mswinsck.ocx is not registered. Of course it isn't as I don't think it exists in Windows 7. Normally I would use regsvr32 to register it but Windows complains that it isn't compatible. I have tried uninstalling most of my applications (mostly 32 bit stuff like Office 2007) but can't seem to find the one that is causing it. I have looked in the event viewer and can see no mention of the error and also turned on boot logging and looked at the log, again no joy.

    Any help would be much appreciated - it's a small thing but very annoying !

    Thanks
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    It 's not installed by default, but have you done a search for it?

    Only thing I can suggest is ti go the one of the DLL /OCX download sites and try to obtain the latest version.

    The whole scenario is strange because that ocx file is self-registering, no need to use regsvr32

    the program that utilizes it automatically registers it.

    Strange?:confused:

    Also, a run-time error usually indicates a incomparable or older DLL file that does not not contain the functions needed.

    Did you recently install any new software?
     
  3. rege0039

    rege0039 New Member

    Joined:
    Jun 11, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for your help. As you say, it is strange.

    I did get a copy of the .ocx, copied it in to windows\system32 and then tried running regsvr32 on it and got told that it was incompatible with this version of Windows (7, 64 bit, RC1 Build 7100).

    I have installed lots of new s/w as I did a fresh install for the RC1. I have tried to got through and work out when it started by deinstalling s/w and seeing if the problem is still there and haven't found a culprit.

    THe strange this is that I have little in my startup group (Logitech Set POint and an old Windows app called Top Desk that is a stand alone app and doesn't install any dll or ocx files) and yet the messages appear only on start-up. As it's Winsck could it be something to do with my network hardware which I did optimize with TCP optimize - but as far as I know that just changes some regsitry setttings.

    Any more comments would be helpful !

    Thanks
     
  4. rege0039

    rege0039 New Member

    Joined:
    Jun 11, 2009
    Messages:
    6
    Likes Received:
    0
    Seem to have solved it by copying the mswinsck.ocx into c:\windows\syswow64. Still not sure why it is needed, seems odd. I will keep checking in to why it needs to be there.

    Just got to get the networking now so I can see other machines in the workgroup
     
  5. TwinA

    TwinA New Member

    Joined:
    Jun 11, 2009
    Messages:
    112
    Likes Received:
    5
    The SysWow64 folder is used for system files (Dlls and such) that are needed in relation to x64 software :) When running a x64 system, it makes perfect sense that the dll must be placed in that folder. In general, if a guide says "do this and that in the system32 folder" - then you should also check the syswow64 folder if you have a x64 system :)
     
    1 person likes this.
  6. Ivan Tang

    Ivan Tang New Member

    Joined:
    Mar 24, 2011
    Messages:
    2
    Likes Received:
    0
    i have the same problem.. run-time error 339.. but instead of asking for mswinsck.ocx, it says im missing BAR32.OCX ... and when i do check syswow64, its actually in there already.. so lost..
     

Share This Page

Loading...