svchost.exe is using up CPU and causing various problems in Windows 7

Discussion in 'Windows 7 Help and Support' started by sven, Feb 11, 2010.

  1. sven

    sven New Member

    Joined:
    Feb 11, 2010
    Messages:
    2
    Likes Received:
    0
    Almost every day I have problems with svchost.exe on my computer. I realize something is wrong when:
    A) Instead of loading a webpage, it simply says "resolving host" for several minutes without making progress
    B) Microsoft Word (2003) opens up, but immediately stops responding, and will not close even when I attempt to close to program from the task manager. Sometimes it takes up to 5 minutes.
    C) My computer just starts running extremely slowly.

    Whenever this happens, I check what processes are running, and invariably svchost.exe is taking up 50% of the CPU. When I end the process, it restarts within 5-10 seconds. Sometimes it is so bad that I have end the process every single time I go to a new website, or it won't load at all. I have run virus scans, with Windows Defender, Spybot Search and Destroy, Ad-Adware, AVG, none of them find anything. Any help would be appreciated.

    I'm running 32-bit Windows 7 Home Premium, on a Dell Inspiron 15, with a Pentium(R) Dual-Core CPU T4200 @ 2.00GHz 2.00GHz, with 3 GB of RAM

    A sidenote, I wonder if the reason svchost.exe is taking 50% of the CPU and not 100% is because it's a dual-core, and it's only running on one? Any help would be appreciated.
     
  2. brianzion

    brianzion Senior Member

    Joined:
    Dec 7, 2009
    Messages:
    23
    Likes Received:
    0

Share This Page

Loading...