system error: -2147020584

Georgey

Well-Known Member
#1
I tried to reinstall a backup program that I had used without any problem.
Now the installation program halted and cited system error: -2147020584.
What is this, and how to fix ?
(I run win 7 ultimate 64 bit; the program was, and is to be, installed on a distinct program drive, not on C.)
Thanks a lot.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#2
Hi Georgey, can you list the name of the program/app in question?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#4
Hi, thanks for the quick reply..

I think the error relates to the actual app itself and is not a Microsoft related error message. I've checked on the main site and they do have quite a good support section as well as a forum: NovaStor Customer Forum • Index page

I've got a hunch that the error relates to the fact your installing the app on a different drive or partition to 'C' but like I say it's only a hunch.. Try the above site for a more conclusive answer and failing that please post back and I'll try to help you further..
 


Georgey

Well-Known Member
#5
Thanks,

I started with NovaStor forum but got viewers only, no reply.
The program had worked perfectly on my drive P (a partition on the hard-drive in my laptop) for half a year.
Now I renamed a few folders, so it'd got the 'right' to stop, but then I used the same installer as earlier.
The full error message is this:
Failed to find node:
/configuration/appSettings/add[@key='DefaultSubscriptionGroup']/@value in XML file:
C:\ProgramData\NovaStor\NovaStor
NovaBACKUP\Profiles\ManagementServer.Agent.Service.exe.config,
system error: -2147020584
 


Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
#6
Thanks,

I started with NovaStor forum but got viewers only, no reply.
The program had worked perfectly on my drive P (a partition on the hard-drive in my laptop) for half a year.
Now I renamed a few folders, so it'd got the 'right' to stop, but then I used the same installer as earlier.
The full error message is this:
Failed to find node:
/configuration/appSettings/add[@key='DefaultSubscriptionGroup']/@value in XML file:
C:\ProgramData\NovaStor\NovaStor
NovaBACKUP\Profiles\ManagementServer.Agent.Service.exe.config,
system error: -2147020584
So from what you say the app stopped working once you renamed certain folders? Have you considered trying system restore? I've searched the net for a meaning to the above error code but non is forthcoming or at least I can't find one for the moment. Why not try asking the Tech support? NovaStor Knowledgebase
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top