Take Ownership, Permisions,Remove Folder/ File Locks, On All in non system Drive

Discussion in 'Windows 7 Help and Support' started by Seven5555, Feb 15, 2013.

  1. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    I have a 2 TB storage drive that I need to remove all locks on all the folders and files. I have been dealing with this nightmare that I have lost and have had to redo weeks worth of work. I have read and tried so many tutorials, take ownership etc. Nothing penetrates the second layer or folders i.e. a folder inside of a folder on the drive.

    Keep in mind that this computer never has been online or a network and never will. It has 3 operating systems which are all windows 7 pro. I have System, everyone, authenticated users, my name and administrator with full control listed in security tab on the drive.

    Is there a way to remove the locks?
     
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    I assume that you have the UAC turned off, so...

    I don't know exactly what's happening but you could try and boot your computer from a Ubnuntu boot disk and see if you can get access to all your files.

    It won't see what Windows has done as far as locking folders etc.

    If you can access them, you can copy them to a new unlocked location.

    Download Ubuntu Desktop | Ubuntu

    Mike
     
  3. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    Thank you very much for responding. I can access everything. Its just a pain having to take ownership or go into security every time I need to use something off of it. Yes I have UAC off. Copying everything to this drive that was unlocked was the lastest thing I tried. So, II have done that. So, Linux won't remove the locks.

    Is there a way to remove the locks?
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    I don't have any other ideas, once I turned off the UAC I got rid of most of my permission problems.

    Maybe someone else here has an idea.

    Mike
     
  5. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    Are you and talking about the same thing? UAC has the notification degree adjustable slider, right? Or am I missing something?

    I have taken a look at the registry settings for "take ownership" and I was hoping maybe I could add something to it to make it actually go into folders and sub-folders etc.? It is only going 1 level then skips a level and then stops, its consistent throughout the drive.

    Who could i talk to about this?
     
    #5 Seven5555, Feb 15, 2013
    Last edited: Feb 15, 2013
  6. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    I know there must be solution somewhere but it looks like its not here. Thanks for you time.
     
  7. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    What about "icacls" from the command prompt using the "grant perm" switch? or am I barking up the wrong tree?

    I just want to create something artistically beautiful from a lifetime of experience, instead I am dealing with access denied messages, context menus, failed attempts to gain unhindered access a non system drive that I access about 50 or more times a day. Has no one else had this issue? When I take ownership of the drive, it just pops up and nothing has changed. I moved everything into a new folder and it got busy and still nada.
     
  8. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    As I said before, when I turned off the UAC virtually all of my problems like that stopped.

    I have four internal hard drives and 4 external hard drives with almost 2 terabytes of data spread over them, and I haven't seen a message that said "Access Denied" on anything in months with the exception of system files or files that were in use by some other software.

    I'm using Windows 8 now and I do think Windows 7 was a little more of a pain in this respect but not as you are experiencing.

    I don't know why you would get this, and I don't know enough about the security programming to suggest a fix.

    Here's a couple of links that may or may not be relevant.
    You may have already tried these but it's all I've got.

    Ignore the first part of the article a look at the part about taking ownership of an entire drive...

    How To Take Ownership of Files or Folders or an Entire Hard Drive

    Not sure about this one, sounds easy but I didn't think you could do this....

    Ownership of a entire drive. - config-customize - windows-7

    Here's another one...

    http://www.preyerplanning.com/take-ownership-of-entire-hard-drive-in-windows-7.pdf


    Mike
     
    #8 MikeHawthorne, Feb 16, 2013
    Last edited: Feb 16, 2013
  9. Adamsappleone

    Adamsappleone U.S.Navy D.A.V.

    Joined:
    Aug 2, 2009
    Messages:
    1,662
    Likes Received:
    122
    Hello Seven5555,

    Have you tried right clicking on the folder you are having problems with, click "Share with", then select "Specific people", then in the Add dialog box click the drop down menu and select "Everyone" or your name if it is not present in the window already, then click "Add', now right click the one you selected or added in the window and select "read/write", then click the Share button.
    That should unlock the folders for you.

    Keep us posted
    Don
     
  10. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    Mike,

    I have seen and tried those. I did retry to verify and show respect to your efforts to read my post and replay in my behalf. Along the way i tried something different and removed 90% of the locks but the actual accessing problem is exactly the same. I am happy that you are not having these problems but i am not prepared to move to windows 8. I had a laptop with it and it seems fine for 99.9% or the populous but for my specfic tasks and habits, It doesn't have a "Start Button" but they put the "up" botton back and windows explorer menus are easy access for most tools... So on and so forth...i'd have to put a lot of time in learning and that will have to wait. Trying to stay on topic and not venture off.

    Thanks for helping me, I think pulling together as a team is always good. Did you read what i asked about ICACLS?
     
    #10 Seven5555, Feb 18, 2013
    Last edited: Feb 18, 2013
  11. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    Adam,

    No I haven't tried any sharing because It's not on a network but I will try that next. I dont know all the specifics but I guess different operating systems on the same mother board should be similar to sharing through a hub. thanks for your help too.
     
  12. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    I'm not pushing Windows 8, if I had it to do over again I would have gotten my new computer with Windows 7 Pro instead.
    But it does seem a little more forgiving on the security angle.

    I use Classic Shell to work with Windows 8, I can't take the interface either.

    But I never had the issues that you are with Windows 7, and that applies to a number of W7 computers that I've used, so there is something unique about your situation and I don't have a clue what it is.

    Mike
     
  13. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    thanks agian, i hate to sound redundant but is there anyone here that CAN help me with this?
     
  14. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    I am not sure how forums works so if this sounds dumb, please forgive.

    Does it do any good to repost or am I to assume that the answer is not here or the right person hasn't seen this yet? What is a good technique to get to the right person or where else should I look? I have to most all the sites at the top of Google list, any advanced members here?
     
  15. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Mike

    All I can say is that wheat you are seeing isn't normal.
    It may be that it's time to do a repair install and see if you can get things back to the default settings.

    If you have a Windows DVD with service pack 1 you can do the whole thing in a half hour.

    Mike

    http://www.sevenforums.com/tutorials/3413-repair-install.html
     
  16. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    I tried to prove you right that this is unique to my situation. I took a 750 g baracuba , formated started created folder with zipped text and copied pasted. I then went into security and added and change users and permsision for more user control because this is a storage drive that needs to easy access but never online or networked. justv one pc with 3 os all win7 pro purchased. locks appeared and cannot be fixed but editing permisions on the drive itself. You said that you have had no propblems with your 3 tbs, what happens when you add a user or change permisions? or have you? I would guess no and advise against it but if you have because its a can of worms that cannot be undone. a but if you have, do you have locks and access issues?
     
  17. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    I asked a couple times about icasls(i think i spelled that rights) and it wasn't even acknowledged along with other questions but I have tried all suggestions with all due respect. This is what i have seen in almost every forum about this issue. I am new to p[osting in forums so i do not want to sound rude. Does anyone here know a way to get access with all of the permissions crap? This drive is not used by anyone but me and never goes online. will going to FAT32 be a solution?
     
  18. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    This is like a virus but worse and in reverse. I dont have a virus but have virus type issues and annoyances and i see this all over the place so i dont think it to be unique.
     
  19. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    I just don't have a clue, like I said I have four internal drives and 3 external drives and I don't get any "you can't open this" messages on any of them now, and I only rarely got a message like that in Windows 7 and then only on isolated files.

    Check out this post and see if there is anything in the commands they discuss that would work for you.

    Windows 7 icacls creating "Special Permissions"

    http://www.edugeek.net/forums/windows-7/59575-icacls-windows-7-modify-permissons-everyone-user-file-folder.html

    Last Idea I have, can you take the drive and plug it into another Windows 7 computer and see if it can be read normally?

    If another computer can just read it with no permissions problems then it would mean that the issues has to be with how permissions on your computer are set up.

    You say you have 3 copies of Windows 7 on the same computer, and none of them can read the drive, maybe the fact that you have so many copies of the OS is causing the problem in some way, i.e. one installation casing problems with another.

    Why do you have 3 copies of Windows 7 on the same computer?
    Is each copy for a different user?
     
    #19 MikeHawthorne, Feb 28, 2013
    Last edited: Feb 28, 2013
  20. Seven5555

    Seven5555 New Member

    Joined:
    Feb 15, 2013
    Messages:
    26
    Likes Received:
    0
    You are not reading what I post or answering questions that i ask, I have already tried it on other computers with windows 7. Its not the only driove or system i have seen this on. Thanks but this is really going no where.
     

Share This Page

Loading...