Task Scheduler corrupted after Win 10 reversion

Discussion in 'Windows 7 Help and Support' started by DeltaD, Jun 20, 2016.

  1. DeltaD

    DeltaD Well-Known Member

    Joined:
    May 8, 2014
    Messages:
    8
    Likes Received:
    3
    Couldn't find anything in searches but I gather this has become a problem for a few others possibly. I only had one task manually set up (as opposed to those Windows does) but after I'd reverted from Windows 10 it didn't run any more. I presumed it was the only one with any issues so didn't worry overly. I tried registry cleanups and various other possible fixes but so far nothing has helped.

    When I opened TS today to try & set it up again I got a raft of about 40 error msgs (The task image is corrupt or has been tampered with) relating to all manner of tasks from printer needs through Google to pretty much every program I've installed!!

    I've not been able to bypass it but as yet haven't tackled DOS type commands etc.

    Really keen to get some help to figure this out & get it fixed. Thanks.
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    I've worked on issues like this with Microsoft before. There's also some information available here.

    Create a registry backup, restore point, run Regedit and browse to

    1) Stop the Task Scheduler service.
    2) Run Regedit and browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    3) Right click the Schedule key and export it to a registry file (yet another backup, yes I know)
    4) Delete the entire Schedule key (and thus it's subkeys will also be deleted)
    5) Restart the Task Scheduler service and see if Task Scheduler will open

    If it still does not, you might as well stop the Task Scheduler service and double click on the .reg file you exported earlier to restore settings.
    Or to be certain you did no further damage, you can restore back to your Restore Point you created earlier.

    Post back with results.
     
  3. DeltaD

    DeltaD Well-Known Member

    Joined:
    May 8, 2014
    Messages:
    8
    Likes Received:
    3
    PERFECT!!! I was a bit concerned initially as when I went to stop the Schedule process I couldn't find any way to do it (was running the service as an Admin) so backed everything up & figured it wouldn't hurt then to just try deleting the key. Of course when I did, I got an Error msg stating that there was a problem "with the command" which I presumed was because of the service still running. But I tried firing up the TS anyway and it worked perfectly (at least that part - not yet tried setting up an actual task). All the previous Windows tasks still seem to be ok so will see how things go.

    But thank you SO much for helping me get it sorted as I've a couple of long tasks I want to run when I'm not around & be able to shut the PC off after x hours will be a great help now. :)
     
    Josephur likes this.

Share This Page

Loading...